Support » Plugin: jQuery Pin It Button for Images » Conflict with Autoptimize plugin

  • So I installed a brand new wordpress on my localhost wamp https://wordpress.org/download/ version 4.7.3 (https://wordpress.org/latest.zip) with the Twenty Twelve default theme and 3 plugins:

    1. WP RECIPE MAKER – Version 1.15.0 | By Bootstrapped Ventures
    2. AUTOPTIMIZE – Version 2.1.0 | By Frank Goossens
    3. jQuery Pin It Button for Images – Version 2.2.7 | By Marcin Skrzypiec

    The recipe rating from the comment section does not because there is a conflict between Autoptimize and jQuery Pin It Button for Images.

    If I disable Autoptimize – it works
    If I enable Autoptmize and disable jQuery Pin It Button for Images it works also.
    But If I keep Autoptimize and jQuery Pin It Button for Images both enabled, it does not work. The star rating which should appear in the comment section is not there.

    It takes less than 10 minutes to set up this environment. I created a single post and inserted a single recipe with only name and description.

    I got this problem on my live website http://www.easyrecipesforkidsguide.com but i wanted to isolate the problem because there I have 21 plugins installed so I did this on localhost and got to only this 3 plugins.

    PS. I posted this problem on all 3 plugins support.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Also seeing this on http://www.peanutbutterandfitness.com/.

    Disabling jquery min in Autoptimize or deactivating this plugin resolves all issues. Excluding this script is effectively the same as deactivating the plugin – no pin button on hover.

    Error when Autoptimize disabled:
    Uncaught TypeError: e.element is not a function
    at jpibfi.client.js?ver=2.2.7:1
    at jpibfi.client.js?ver=2.2.7:1
    (anonymous) @ jpibfi.client.js?ver=2.2.7:1
    (anonymous) @ jpibfi.client.js?ver=2.2.7:1

    Error when both running:
    Uncaught TypeError: Cannot read property ‘hover’ of undefined
    at jpibfi.client.js?ver=2.2.7:1
    at Object.i.10../debugger (jpibfi.client.js?ver=2.2.7:1)
    at r (jpibfi.client.js?ver=2.2.7:1)
    at n (jpibfi.client.js?ver=2.2.7:1)
    at jpibfi.client.js?ver=2.2.7:1
    at jpibfi.client.js?ver=2.2.7:1

    First noticed: March 8, 2017

    Yes I saw that. It is a problem from jQuery Pin It Button for Images plugin. It has an error inside it and that shows even if Autoptimize is on or off. If the author won’t fix the problem, I will be forced to uninstall this plugin.

    I have to mention that this error wasn’t until the last update.

    same problem here, already opened a thread week ago and still not reply from the author even with a pro version…not very serious!

    i removed that plugin.

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @paulalexandru,

    just to let you know, the issue will be fixed in the next release of the plugin in a few days.

    @recyclart: Since you’re a pro user, why didn’t you contact me via email? I don’t always have time to help out on the forum, but I always reply to pro users who email me.

    Plugin Author mrsztuczkens

    (@mrsztuczkens)

    Hey @paulalexandru,

    in case you’re still interested in the plugin I wanted to let you know that I just released a new version that should fix this bug.

    OK

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Conflict with Autoptimize plugin’ is closed to new replies.