Support » Plugin: JWT Auth - WordPress JSON Web Token Authentication » Conflict with AutomateWoo plugin – running manual workflows

  • Hi there,

    I have come across an issue today where we tried to run a manual workflow using the AutomateWoo plugin and it crashes – empty page. And threw an error related to JWT Auth.

    I can confirm deactivating JWT Auth allows the AutomateWoo plugin to run as normal.

    First error we saw is:

    react-dom.min.js?ver=16.13.1:125 TypeError: Cannot read property 'toString' of undefined
        at $t (index.js?ver=6edb0adc8cc3ae7df23c2c6be02147f9:2)
        at we (react-dom.min.js?ver=16.13.1:84)
        at He (react-dom.min.js?ver=16.13.1:97)
        at zj (react-dom.min.js?ver=16.13.1:228)
        at Th (react-dom.min.js?ver=16.13.1:152)
        at tj (react-dom.min.js?ver=16.13.1:152)
        at Te (react-dom.min.js?ver=16.13.1:146)
        at react-dom.min.js?ver=16.13.1:61
        at unstable_runWithPriority (react.min.js?ver=16.13.1:25)
        at Da (react-dom.min.js?ver=16.13.1:60)
    

    Then we tried a change in the AutomateWoo code and got a bit further but it showed us this error in the screenshot:
    {"success":false,"statusCode":403,"code":"jwt_auth_no_auth_header","message":"Authorization header not found.","data":[]}

    So I suspect we need to do something to allow this to run… but not too sure.

    Any insight would be greatly appreciated.

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Bagus

    (@contactjavas)

    Hi @benbodhi , thanks for posting this.

    I think you need to whitelist the namespace/ endpoints used by the plugin. If you’ve found it, you can use jwt_auth_whitelist filter to whitelist it.

    Let me know if you’ve tried it and the error is still there.

    Regards,
    Bagus

    Thread Starter Benbodhi

    (@benbodhi)

    Thanks for your quick reply!

    Where would I find the namespace/ endpoints that AutomateWoo would use?

    Thread Starter Benbodhi

    (@benbodhi)

    Also, I noticed that you have a discord, but the old invite didn’t work, I’d love to jump in to your server 🙂

    Plugin Author Bagus

    (@contactjavas)

    Hi @benbodhi , you can find it by visiting the option page of that plugin in admin area. As you aready know:

    • open Developer Tool (f12 in chrome in windows)
    • then go to Network tab -> XHR tab
    • then reload the page.

    Try to find the url that seems related to that plugin. If you’ve found it, go to the documentation page and search for jwt_auth_whitelist word

    You can use this link to join the Discord channel.

    See you there 🙂
    Thanks,
    Bagus

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Conflict with AutomateWoo plugin – running manual workflows’ is closed to new replies.