Support » Plugin: Store Locator Plus for WordPress » Conflict with Atahulpa 3.7.8?

  • Resolved taxoneonone


    Well. I guess I’d have no luck finding out the answer myself. I noticed two websites reported no show of Google Maps after installing the plugin, and the problem probably came from AJAX listener conflict of the theme used.

    I’m using theme Atahulpa 3.7.9 which is a really good one, but also conflicts many plugins b/c I don’t know how to fix them, mostly .js file links I guess.

    Can anybody point out what the conflict is here with SLP? Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Store Locator Plus


    Not surprising it breaks, they’ve disabled jQuery which is a base script used by many plugins and themes. I think parts of WordPress use it as well though I’m not 100% certain on that. It *IS* a part of the core WordPress product distribution though.

    The SLP plugin set jQuery as a dependency, but they are forcing it back off for who-knows-what reason.

    Without jQuery this plugin has no chance of working properly as 90% of the UI functionality requires it.

    Argh! Themes that do this should be deleted on sight!

    @taxoneonone: Use another theme. This one will give you nothing but trouble.

    Thanks for your quick answers. Well, I realized it might not be the theme who should be to blame. After I deactivated one plugin “JS & CSS Script Optimizer Version 0.2.3”, Google Maps worked without a problem…

    This plugin “JS & CSS Script Optimizer” works in a way to combine/streamline js/css files to reduce loading time. But no matter how I configure this plugin, “store Locator Plus script not loaded properly”.

    Now I got it. Thanks!

    If you have a solution to make both plugins work, that’s be even better. 🙂

    Plugin Author Store Locator Plus


    The solution would be to see if JS & CSS Script Optimizer can stop killing the jQuery script from loading. The only thing I can do for SLP is tell WordPress “hey I need jQuery”, then WordPress does the rest.

    Something in JS/CSS Script Optimizer is stopping that. I would imagine (hope) they have a setting to leave jQuery turned on.

    Thanks! I tried the several options available in this plugin… but still failed to make both compatible… So, in order to make life easier, I just removed that Optimizer. Hopefully I can find a replacement soon or an expert who can help streamline my code sometime 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Conflict with Atahulpa 3.7.8?’ is closed to new replies.