Support » Plugin: WPForms Google Sheet Connector » Conflict with another plugin that also uses Google API

  • Resolved alexbosch

    (@alexbosch)


    Hi;

    I found a incompatibility with Rank Math Google Instant Indexing plugin. If both plugins are enabled they crush and none is working. If I disable any of them, the other one works perfectly.

    Both plugins use Google API connection… maybe this information could help.

    What can we do to solve that problem?

    Thank you in advance

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter alexbosch

    (@alexbosch)

    This is the response from Rank Math:

    “We checked the plugin you mentioned and noticed that it’s also using the Guzzle HTTP library but there seems to be a mismatch between the version we use and the version that the plugin uses which could cause this issue.

    Because of that when our plugin is trying to make use of that library is encountering issues calling the right functions and as such, they can’t be used at the same time because of this conflict.”

    Can you please tell me something?

    Thank you

    Plugin Author westerndeal

    (@westerndeal)

    Hello @alexbosch

    Thank you so much for getting in touch.

    Let me update the library and I’ll send you a link to download and to check on your site, if it works then we’ll update the plugin publicly.

    Thanks
    Abdullah

    Thread Starter alexbosch

    (@alexbosch)

    Hi, @westerndeal

    Perfect! Let me know when I can try it.

    Thank you!

    Plugin Author westerndeal

    (@westerndeal)

    @alexbosch

    Please download this plugin file and replace it with the existing one and check!
    Let me know if it works!

    Thanks
    Abdullah

    Thread Starter alexbosch

    (@alexbosch)

    Hi @westerndeal

    No, it didn’t work… I’m sorry

    Thank you

    Plugin Author westerndeal

    (@westerndeal)

    @alexbosch

    Can you send me the exact error you are getting so that based on that I can help!
    Send me the error log here or attach screenshot!

    Thanks

    Thread Starter alexbosch

    (@alexbosch)

    Hi @westerndeal

    This is the error I received from WordPress:

    Error details
    ==================
    An error of type E_COMPILE_ERROR occurred on line 36 of the file /var/www/vhosts/babyledweaning.website/httpdocs/wp-content/plugins/gsheetconnector-wpforms/gsheetconnector-wpforms.php. Error message: require_once(): Failed opening required ‘/var/www/vhosts/babyledweaning.website/httpdocs/wp-content/plugins/gsheetconnector-wpforms/includes/class-wpforms-integration.php’ (include_path=’.:/opt/plesk/php/7.4/share/pear’)

    If you need anything else, just let me know.

    Thank you.

    Thread Starter alexbosch

    (@alexbosch)

    Hi @westerndeal

    How is it going? Did you need anything else to solve the problem?

    Thank you

    Thread Starter alexbosch

    (@alexbosch)

    Hi @westerndeal

    I sent the error four weeks ago. Can you please say me something?

    Thank you

    Plugin Author westerndeal

    (@westerndeal)

    Hello @alexbosch
    Thanks for getting in touch and sorry for the delay in responding,

    We are still into testing with the above addon,
    As mentioned, the issue is with the “Guzzle HTTP library” version

    We have updated with the latest, We would be sending you a link with the latest library files in a couple of days to test, if still there would be an issue, ‘Rank Math Indexing’ needs to update the plugin library,
    It happens because of a version mismatch, I’ll update you in a couple of days.

    Thanks
    Abdullah

    Thread Starter alexbosch

    (@alexbosch)

    OK. I’ll wait for your update. Thank you so much!

    Plugin Author westerndeal

    (@westerndeal)

    @alexbosch
    You can download the plugin files from here (to test)
    https://drive.google.com/file/d/1OLqqpklTl5mH8bcUTCDnAaJ_lgeClnK6/view?usp=sharing

    Rank Math Indexing plugin GuzzleHttp Version is 6.5.5
    whereas GSheetConnector WPForms Plugin GuzzzleHttp Version is 7.x.x (using latest)
    Therefore, It requires to request Rank Math Developers to update the GuzzleHttp Version

    Let me know further.

    Thanks
    Abdullah

    Thread Starter alexbosch

    (@alexbosch)

    Hi @westerndeal

    Thank you so much for your efforts, but it didn’t work. I will contact again Rank Math support to ask if they could try to solve it.

    Thank you and have a nice day.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.