Support » Plugin: SiteGround Optimizer » Conflict with All in one SEO

  • Resolved omahoung

    (@omahoung)


    Hello,

    I have a conflict on a site using both All in one SEO and SG optimizer. When all in one is deactivated all is fine. When I activate All in one SEO, the website breaks on SG Optimzer CSS files minify activation. I get this message:

    Fatal error: Uncaught MatthiasMullie\Minify\Exceptions\IOException: The file "/home/ilearningtutor/public_html/dev/wp-content/plugins/all-in-one-seo-pack/dist/Lite/assets/css/aioseo/css/admin-bar.css.min.css" could not be opened for writing. Check if PHP has enough permissions. in /home/ilearningtutor/public_html/dev/wp-content/plugins/sg-cachepress/vendor/matthiasmullie/minify/src/Minify.php:476 Stack trace: #0 /home/ilearningtutor/public_html/dev/wp-content/plugins/sg-cachepress/vendor/matthiasmullie/minify/src/Minify.php(236): MatthiasMullie\Minify\Minify->openFileForWriting('/home/ilearning...') #1 /home/ilearningtutor/public_html/dev/wp-content/plugins/sg-cachepress/vendor/matthiasmullie/minify/src/Minify.php(153): MatthiasMullie\Minify\Minify->save('#wpadminbar #wp...', '/home/ilearning...') #2 /home/ilearningtutor/public_html/dev/wp-content/plugins/sg-cachepress/core/Minifier/Minifier.php(199): MatthiasMullie\Minify\Minify->minify('/home/ilearning...') #3 /home/ilearningtutor/public_html/dev/wp-content/plugins/sg-c in /home/ilearningtutor/public_html/dev/wp-content/plugins/sg-cachepress/vendor/matthiasmullie/minify/src/Minify.php on line 476

    I am not sure if this is a All in one or SG Optimizer bug.

    Does anyone had a similar problem?

    Thanks.

    • This topic was modified 4 months ago by omahoung.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support Dimitar Petrov

    (@demiro)

    Hey @omahoung,

    I have installed the All in one SEO plugin on my end but was unable to replicate the issue.

    According to the error that you provided, the issue is caused by insufficient Linux file permission levels. You should check the files’ required permission by your hosting service and set them.

    You can also try setting up a filter for the CSS file in question, which should be as follows.

    add_filter( 'sgo_css_minify_exclude', 'css_minify_exclude' );
    function css_minify_exclude( $exclude_list ) {
        // Add the style handle to exclude list.
        $exclude_list[] = 'aioseo/css/admin-bar.css';
    
        return $exclude_list;
    }

    Please note that I used the CSS handler for the last All In One SEO version, which could be different on your end.

    Regarding your last question, no such issue was reported on our end.

    Regards,
    Dimitar Petrov

    Thread Starter omahoung

    (@omahoung)

    Thanks for the fast answer.

    The folders and files permissions looks normal (755 for folders, 644 for files). But anyway the problem is that this last part of this path doesn’t exists. The path exists until here:

    
    /home/ilearningtutor/public_html/dev/wp-content/plugins/all-in-one-seo-pack/dist/Lite/assets/css/
    

    Inside this last css folder there are only files, no folders, so aioseo/css/admin-bar.css just doesn’t exists. I wonder where this path comes from… could it come from SG Optimizer?

    Adding the filter you gave me solved the issue, thanks, but this doesn’t seem a very clean and definitive solution to me.

    I have updated to the last version of All in one SEO, the problem is the same.

    Kind Regards

    Plugin Support Dimitar Petrov

    (@demiro)

    The file from the initial error should exist, it is registered by the plugin, and also exists on my end. The path is not generated by our plugin. If the aioseo/ directory is missing on your end, I would recommend completely reinstalling the plugin or double-checking the Linux permission and ownership of the directories in question.

    Regards,
    Dimitar

    Thread Starter omahoung

    (@omahoung)

    I have just downloaded the lite version (4.1.10) from the WordPress repository and there is no aioseo/css/admin-bar.css in the plugin zip file, same after installing on any website, this folder is not created.

    Which version of All in one SEO do you have? Lite or pro?

    I will ask to All in one about this file.

    Regards.

    Plugin Support Delyan Delov

    (@delyandelov)

    Hi @omahoung,

    I have just installed All-in-one-SEO plugin (version 4.1.10 Lite) and the folder aioseo/ was created successfully. I have disabled and then enabled the CSS Minification in SG Optimizer plugin (version 7.0.9) and then cleared the cache using the Purge SG Cache button. The problematic file was created:

    /wp-content/plugins/all-in-one-seo-pack/dist/Lite/assets/css/aioseo/css/admin-bar.css.min.css

    and the site is loading properly at the moment (both front and back-end).

    Thread Starter omahoung

    (@omahoung)

    I am not sure to understand your answers.

    In a previous message you said:
    “The path is not generated by our plugin”.

    And now you say:
    “and then cleared the cache using the Purge SG Cache button. The problematic file was created”.

    Is this file created by the SG Optimizer plugin or not?

    Plugin Support Delyan Delov

    (@delyandelov)

    No, the folder is not created by our SG Optimizer plugin. I have just described the steps I have done before the folder was created by the AIOSEO plugin:

    1. activate the AIOSEO plugin
    2. access the site’s frontend while you are logged in
    3. clear the SG Optimizer cache if needed

    After that, the folder should be created and the error should not appear when activating the CSS Minification.

    Thread Starter omahoung

    (@omahoung)

    I got an answer from All in one SEO:

    The file that’s being looked up shouldn’t exist since the equivalent in 4.1.10 should be admin-bar.654f4913.css. So this seems to be a caching issue and there might be some very aggressive caching going on here (possibly OPCache).

    So it looks normal that I don’t have this file.

    Could you please check again from your side, this could be a cache problem.

    Thanks.

    Plugin Support Delyan Delov

    (@delyandelov)

    Most probably the support of All-In-One-SEO plugin have mistaken the file because both of them do exist on my end:

    /wp-content/plugins/all-in-one-seo-pack/dist/Lite/assets/css/admin-bar.654f4913.css

    and

    /wp-content/plugins/all-in-one-seo-pack/dist/Lite/assets/css/aioseo/css/admin-bar.css.min.css

    As you can see they are located under different folders. I am using the latest version of the plugin (4.1.10) as well. The second sile is generated only when the frontend is accessed while the user is logged in.

    AIOSEO dev here.

    The all-in-one-seo-pack/dist/Lite/assets/css/aioseo/ is not a folder that exists in our plugin. You can verify this by downloading the latest version and unzipping it. Similarly, the assets/css/aioseo/css/admin-bar.css.min.css file also does not exist in our plugin.

    I’m not familiar enough with Siteground Optimizer to say whether your plugin is generating those files, but they are definitely not included by default by us. A third-party plugin is generating them.

    Plugin Support Delyan Delov

    (@delyandelov)

    Thank you for the clarification, @arnaudbroes!
    I will consult with our developers and will get back to you with more information.

    Plugin Support Delyan Delov

    (@delyandelov)

    I have discussed the case with our developers and indeed the folder is generated by our plugin. This appears to be a corner case because generally, our plugin is using the script handle in order to create the minified file.

    However, in this case, the handle for the admin-bar.654f4913.css is actually (aioseo/css/admin-bar.css) which is not a typical one. This is how the folder aioseo/css/ is created.

    Our developers will implement a fix for such cases in future releases of the plugin. Until then, I would suggest using the filter provided above in this thread.

    Thread Starter omahoung

    (@omahoung)

    I will use the filter. I hope this will not take too long time to get the fix.
    Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.