Support » Plugin: Jetpack by WordPress.com » Conflict with Advanced Custom Fields/ACF

  • Resolved Josiah

    (@colewebdev)


    WordPress 4.8
    Jetpack 5.1
    ACF 4.4.11

    Saving field groups causes fields to disappear from admin. Unable to add new fields.

    Isolated Jetpack by disabling all my plugins, and reactivating until I found the the behavior exhibited.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Same problem. Took me a while to figure it out, then when googling with the plugin version numbers, I found this post.

    Tried disabling functionality in JetPack, which did not resolve the issue.

    Tried installing the plugin “Module Control for Jetpack” by RavanH, where I disabled everything, this also did not resolve the issue

    Tried disconnecting JetPack from a wordpress.org account. When JetPack is not connected to a wordpress.org account ACF seems to work. I can add fields to field groups that is. Of course not having JetPack connected is another problem itself.

    Yes, you are correct in that the “connection” to WordPress.com is what caused the bug. JetPack doesn’t even activate/function without connecting to WP.com so I just dropped it, as ACF is higher on my list of requirements.

    Hi @samstetler and @colewebdev

    Thanks for getting in touch with us. Would you guys mind telling me where the fields are missing, are they missing in the editor or else I am not familiar with the ACF plugin, however I did install it to test on my site but wasn’t able to replicate. Could you guys let me know the steps you took to replicate this issue? I’ll be able to report this to our developers as soon as I can confirm this affecting my sites too, otherwise if it’s not widespread we can work through some debugging to see what exactly is causing this.

    Cheers.

    Install / setup a field group with ACF
    Then install Jetpack / activate.
    Edit your existing ACF field group (add a field etc.) and then “update” the field group.
    All fields in the editor disappear.
    Deactivate Jetpack, and they appear.

    The particular install I had the issue with was hosted at WPEngine.

    Hello, Dear.

    I found the the same behavior.

    I want to resolve it

    I have the same problem. My blog needs Jetpack installed, so I really have to solve this.
    Thanks!

    I am also having the same problem. I currently have Jetpack disabled so Advanced Custom Fields works. I went through and activated other plugins one by one, and it’s definitely Jetpack causing the problem.

    Hello,

    I have the same issue, using:
    Wordpress 4.8.1
    Jetpack 5.2.1
    ACF 4.4.11
    Hosted on WP Engine

    Steps to replicate:
    1. Before activating Jetpack go to the CF dashboard section, add a field group and create a custom field under it.
    2. Activate and connect Jetpack.
    3. Go back to the CF dashboard on the previous field group and click update (no need to create a new CF).
    4. All custom fields under that field group will then disappear. They will also not show up under the concerned posts.

    Thanks!

    Hey All,

    Sorry about the delay in writing back to you. Our developers have picked up on the issue and it’s being tracked here:

    https://github.com/Automattic/jetpack/issues/7565

    The problem appears to be a perfect storm of a few different pieces. One of the developers suggested a possible workaround of manually setting one of Jetpack’s options:

    Jetpack_Options::update_option( ‘image_widget_migration’, true );

    Hi, I have the same problem.

    ACF and Jetpack are both essential to run a WP site. So the two being friends is indispensable. Issue track on Github seems to be closed. Though with everything updated to latest version, I’m still getting the error.

    Hope this can be resolved soon.

    Thank you.

    You can easily add me (and I suggest many others, how much jetpack – installations are live?) to this topic. After deactivating jetpack it was possible to add new fields, but this can´t be a real solution as jetpack is needed for so many reasons.

    I wouldn´t like to try and search for other “custom field” – plugins, so it would be nice and kind to update it so it will be working with jetpack, too.

    And I don´t understand the last post of IamDay – in which file did I have to set this jetpack option?

    lamday

    (@lamdayap)

    Hi there,

    Just an update on the conflict – it looks like our developers have a patch for this which is currently in beta and expected to be in our next update.

    We’re expecting the release to come out soon however if you want to try the beta plugin, you can find a download link and instructions here:
    https://jetpack.com/download-jetpack-beta/

    kiezkickerde

    (@kiezkicker)

    Working as it should be, thanks for the quick relaese of the stable version.

    I am having this same issue now with this plugin:

    “WP to Buffer Pro”

    Wordperfect 4.8.2
    WP To Buffer Pro 3.3.9

    I can create field group, and can edit and save location and options. But when I add new fields then hit save or update, it wipes out the fields. Location and Options will update.

    When I disable the WP to Buffer Pro plugin, it works fine and I’m able to create fields. Also the fields will display on Edit Post pages. But if attempt to update the custom fields settings it will wipe them out of the admin section.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @sassergroup If the conflict is between WP to Buffer Pro and ACF, it might be best to report it the plugin author; there is not much I can do for you on my end I’m afraid.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Conflict with Advanced Custom Fields/ACF’ is closed to new replies.