Support » Plugin: Radio Buttons for Taxonomies » Conflict with Advanced Custom Fields

  • Hello,

    I noticed that the Advanced Custom Fields field groups in my wordpress build don’t expand when my users click on the labels, after the user has selected a category. I discovered that the issue is coming from a conflict with Radio Buttons for Taxonomies. To reproduce this issue:

    Install ACF and Radio Buttons for Taxonomies
    Enable Radio Buttons for Taxonomies for Categories
    Add a few ACF fields for Posts, and include them in the sidebar
    Add New Post
    Add a title
    Select a category, and close the Category panel.
    try to interact with the ACF fields.
    If it still interacts, try adding a Featured Image, and then try to interact with the ACF fields.

    In order to get around this, my users need to save the draft and reload the page.

    I looked at your javascript to see if there may be some conflict with the adding/removing the .hidden class for those field groups, but I didn’t see anything that jumped out at me. I will update this topic if I find anything.

    WP 5.7.1
    ACF 5.9.5
    Radio Buttons for Taxonomies 2.3.1

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author HelgaTheViking

    (@helgatheviking)

    Hi Pete… is your issue the same as this one?
    https://github.com/helgatheviking/Radio-Buttons-for-Taxonomies/issues/71

    or is it separate, but still related to ACF? Are you getting any particular script error? Are you referring to the block editor or the classic editor?

    Not sure this is something I can fix on my own, would probably need to get the ACF team involved. Some cross-compat issues are just really complex.

    Thread Starter petefuseloft

    (@petefuseloft)

    Hi Helga,

    This could be the same issue. Unfortunately I’m not seeing anything in the console, but this could reveal more information:

    ACF field groups have this in the class attribute: postbox acf-postbox closed

    If you click on the label, “closed” toggles on and off.

    If I start a new post, expand “Categories”, and select one of the radio buttons, this interaction no longer works. “closed” remains in the list of classes on the ACF field group when I click the label.

    This leads me to believe that there might be some conflicting javascript. I’ll let you know if I get any further.

    Thread Starter petefuseloft

    (@petefuseloft)

    Hi Helga,
    This might help narrow things down:

    There is a plugin called Categories Metabox Enhanced that has a similar functionality to yours. It looks like the same issue occurs with this plugin when using radio buttons, but if you choose Select instead of Radio Buttons, the issue doesn’t occur.

    Plugin Author HelgaTheViking

    (@helgatheviking)

    Hi Pete,

    What do you mean by “include them in the sidebar”? I only saw options for “metaboxes” and “seamless”.

    I’ve made a few fields:
    https://share.getcloudapp.com/4gu2gN4G

    with these field settings:
    https://share.getcloudapp.com/z8u6eGlj

    And I seem to be able to interact with them in the post editor:
    https://share.getcloudapp.com/2NuwNb7Q

    Is there something else I need to do to replicate this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Conflict with Advanced Custom Fields’ is closed to new replies.