• Resolved alec527

    (@alec527)


    Hello,
    I’m encountering a conflict between Autoptimize and WooThumbs by Iconic. When I disabled JS optimization, the page stopped loading (loaded completely blank). When I disable either Autoptimize or WooThumbs, the page works fine. When I add WooThumbs to the JS exclude list (“plugins/iconic-woothumbs”), there is no effect. Could you please help me figure out how to fix this conflict?

    Thanks,
    Alec

    The page I need help with: [log in to see the link]

Viewing 3 replies - 16 through 18 (of 18 total)
  • Thread Starter alec527

    (@alec527)

    Ok, I’m happy to disable on the relevant pages – I’m noticing that the WooCommerce Product edit pages don’t have that metabox – is there a code snippet I could add so that it appears there?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I think this (untested!) snippet should disable AO on product pages;

    add_filter( 'autoptimize_filter_noptimize',
      function() {
        if ( is_product() ){
          return true;
        }
        return false;
      }
    ,10,1);
    Thread Starter alec527

    (@alec527)

    Thank you, that works!

Viewing 3 replies - 16 through 18 (of 18 total)
  • You must be logged in to reply to this topic.