Support » Plugin: WP-Optimize - Cache, Clean, Compress. » Conflict after latest update

  • Resolved lkafrazier

    (@lkafrazier)


    Hello, something has changed recently on our site and I’m not sure exactly what is causing it. I have isolated the issue to a conflict with the WP – Optimize plugin. When I deactivate the plugin, everything works fine. Here is what is happening though, when the plugin is activated:

    We have a current Pre Order open. When the customer goes to the shop page for the preorder listings, all the products show. Each one has a button under it that says “Select Options” because we offer it in many different substrates. When the customer hits the Select Options button it takes them to another screen where they can choose the substrate and then the quantity. From here….the button used to say “Pre Order Now” and it would add it to their cart. However all of a sudden, when they hit the ADD TO CART button, it takes them to another screen….where up at the top there is now a red warning strip that says ” ! Please choose product Options”…but they already have done that. On this screen, if they hit the PRE-Order Now button it goes ahead and adds it to their cart, but this red warning is confusing both us and our customers.

    I’m not really sure why the WP-Optimize would be causing this issue…but as soon as I deactivate that particular plugin, the order screen, and cart work just fine and the warning no longer exists.

    Any help you can provide would be much appreciated!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Harshad

    (@bornforphp)

    @lkafrazier Could you please try to add the urls of the particular page to “URLs to exclude from caching” from WP-Optimize > Cache > Advanced Settings and check if it helps to fix the issue?

    Thread Starter lkafrazier

    (@lkafrazier)

    Thank you for the reply. I did this and it did not fix the issue.

    Plugin Support Harshad

    (@bornforphp)

    @lkafrazier Could you please try to turn off minify options, and check if it helps to fix the issue?

    Thread Starter lkafrazier

    (@lkafrazier)

    Yes! Disabling minify options resolves the issue. Is there a way to fix the conflict though so that we can enable it again? We really need the reduced load times and bandwidth usage b/c our website speed is blah without it. 🙂

    Plugin Support Harshad

    (@bornforphp)

    @lkafrazier Could you please enable Minify and uncheck the Merginf of JS and CSS file option from WP-Optimize > Minify > Javascript and CSS and chec if it helps to fix the issue?

    Thread Starter lkafrazier

    (@lkafrazier)

    Yes…when I enable minify and then unchecking JS and CSS works fine.

    Plugin Support Harshad

    (@bornforphp)

    @lkafrazier Glad to hear its working fine now, If you have any more questions, please feel free to write back to us.

    Thread Starter lkafrazier

    (@lkafrazier)

    Thank you for your help! By unchecking the JS & CSS ability to minify though, those parts of our website won’t be able to be minified? Won’t this affect part of our speed? Bandwidth usage and loading times?

    Plugin Support Harshad

    (@bornforphp)

    @lkafrazier It won’t really affect that much, but yes will slightly affect the speed, but as its incompatible with your theme, so you may have to uncheck the option.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.