Support » Plugin: Autoptimize » Conflict

  • Resolved Oliver Nielsen

    (@oliver-nielsen)


    Hi Frank
    Thanks for your plugin Autoptimize.

    Now I have run WP-debug in Chrome. I get this jQuery message:

    autoptimize_c0180fb….js:10 JQMIGRATE: Migrate is installed, version 1.4.1
    autoptimize_c0180fb….js:82 Uncaught TypeError: a.target.className.indexOf is not a function
    Uncaught TypeError: a.target.className.indexOf is not a function (

    Do you know what to do?

    I also get this message in page:

    Warning: preg_match() [function.preg-match]: Compilation failed: a numbered reference must not be zero at offset 18 in /var/www/minmadopskrift.dk/-//w3-total-cache/PgCache_ContentGrabber.php on line 737

    Regards
    Oliver

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Frank Goossens

    (@futtta)

    Evening Olivier;
    1. the JQMigrate is normal
    3. the preg_match isn’t autoptimize, but W3TC

    which leaves us with (2).

    so some questions about that;
    * do you see anything broken and if so, what?
    * do you see the same error-message when going to that page with ?ao_noptimize=1 appended to the URL?
    * are you using default JS optimization settings (“force into head” not active, “aggregate inline JS” not active, js/jquery/jquery.js excluded from JS optimization?

    frank

    Evening Frank
    Thanks for your super speed answer.

    In addition, solve the error.

    Excluding js/jquery/jquery.js removes the error.

    But, now I got one more render blocking file: js/jquery/jquery.js

    Maybe I can solve this by Inline and Defer? I will check this nice feature out someday.

    The prematch is W3TC yes and not A , it was just for info.

    Thanks for solving problem so fast Frank!

    Best Regards
    Oliver

    Plugin Author Frank Goossens

    (@futtta)

    Excluding js/jquery/jquery.js removes the error.
    But, now I got one more render blocking file: js/jquery/jquery.js

    excluding something from optimization generally also means it will be render blocking, so you will either have to live with the error (not sure if something was broken) or you’ll have to live with the fact that one file is render-blocking.

    inline & defer only helps for render-blocking CSS I’m afraid ..

    Hi Frank
    Thanks for your answer.
    About the inline and defer thing, I am not me, when I am tired 😉 Yes, it is a CSS subject; you are totally right about that.

    On the homepage, yes, I have no errors anymore; however, I noticed today, that I get the same error in all posts?
    Then I deactivated Autoptimize and the error was still there, but now another plugin name shoved up in chrome de-bug mode rapport instead of Autoptimize. I think this plugin give the errors on posts.
    I do not know why Chrome show Autoptimize, but maybe a cache thing.

    One last question

    I only have one render blocking js file now, js/jquery/jquery.js. Any Idea what I can do with this file. I have tried W3TC without luck.

    Many thanks for your patience Frank

    Regards
    Oliver

    Plugin Author Frank Goossens

    (@futtta)

    if a plugin introduces JS that throws errors, the same error will pop up when autoptimizing your JS, the only difference being the source of the error (the plugin’s JS or the autoptimized JS that now contains the faulty code). better talk to that plugin’s developer 😉

    I only have one render blocking js file now, js/jquery/jquery.js. Any Idea what I can do with this file.

    you can try removing js/jquery/jquery.js from AO’s JS exclusions and check if your site still works, but that’s it I’m afraid. sometimes one has to sacrifice 😉

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Conflict’ is closed to new replies.