Support » Plugin: Google Forms » Confirmation Redirect

  • Resolved myladeybugg

    (@myladeybugg)


    Hi Mike,

    I am using the shortcode with a specific confirmation page. I notice during the redirect the user is first redirected to the google confirm page and then the custom one. Is there no way to send them straight to my confirmation page? I noticed you mentioned you can’t go back to the previous redirect, but I’m unsure what that was since I just downloaded the plugin for the first time.

    Thanks!

    http://wordpress.org/extend/plugins/wpgform/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    Because Google Forms can be multiple pages, there isn’t a way to know whether the submit action is a “continue” to the next page or a “submit” for the final time.

    From a HTML state perspective, both operations are the same, it is a “submit”. How Google responds to the submit, either with the next page of the form or with a confirmation page, isn’t easily detected. It isn’t until the form is known “done” that the custom confirmation page redirection is output but by that time, the response from Google has already been added to the page.

    How quickly your page loads will dictate whether or not you will see the Google Confirmation when you’re using a custom confirmation page. What you may want to try is the following:

    1. Use AJAX as the confirmation type.
    2. Add the following to your Custom CSS which will hide the confirmation content from Google:
      div.ss-custom-resp {
          display: none;
      }

    It is worth a shot to see if it will achieve what you want to do.

    Thanks Mike! I’ll give it a shot!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Did my suggestion work for you?

    Plugin Author Mike Walsh

    (@mpwalsh8)

    Marking this issue as resolved, let me know if this is still an issue.

    Mike,

    I tried adding the Custom CSS you suggested, and setting the style to AJAX and I still am having the redirect issue. The page is not loading quickly enough to avoid users seeing both confirmations. I like the custom confirmation, but if I can’t prevent it from showing both, I’ll probably disable it to avoid confusion from our users. The form is here: http://www.krausfitch.com/contact-us/cohousing

    Plugin Author Mike Walsh

    (@mpwalsh8)

    If you are still able to view the content of the Google generated confirmation page then I suspect the CSS to hide it isn’t correct. I would do the following:

    1. Turn off the redirect.
    2. Work out the CSS (I can help here if it is ok to submit responses to your form) to hide the Google generated confirmation content.
    3. Once the Google confirmation is suppressed, re-enable the redirect.

    Trying to work out the correct CSS will be hard with the redirect enabled.

    Mike,

    You’re welcome to submit responses… I’ve been running a number of test responses while I set things up, so I’ll need to go in at the end of today and clear out the response log anyway. I don’t really know enough about CSS to try to work it out myself… I’ve got just a bit of basic knowledge. (When I invent that extra day in every week, it’s high on my list of things to learn.) But if you have suggestions, I’ll definitely try implementing them.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I finally had a chance to look at this, was traveling yesterday.

    Try adding the following to your Custom CSS:

    div.ss-resp-card {
        display: none;
    }

    I was able to suppress the Google content with that using FireBug.

    Mike,

    Looks like that does suppress the Google content. The redirect still happens, but it’s much cleaner to just have the one line of text from the previous page, and then the redirect to the confirmation. I’ll clear out the response log with all the tests. (Unless you’d actually like to be on our mailing list? 😉 )Thanks for the help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Confirmation Redirect’ is closed to new replies.