Support » Plugin: WordPress Newsletter Plugin - Noptin » Confirmation link not working

  • Resolved ohgoodiee

    (@ohgoodiee)


    Hello. This is a good, lightweight plug-in that I really want to get working, but the link that is sent in the confirmation email doesn’t work.

    Everything else works like a charm.

    Thanks much in advance

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am able to reproduce this as well. After clicking the confirmation link in the email, it take you to a page and says “Unable to confirm your subscription to this newsletter.” I made another topic for unsubscribing in general without the confirmation email. Unsubscribing in general doesnt work at all.

    • This reply was modified 10 months, 2 weeks ago by basshead.
    Thread Starter ohgoodiee

    (@ohgoodiee)

    For the developer. If you want to see the error that we are getting, here is a link that was sent to confirm email.

    https://verygood.coffee/index.php/noptin-page/?na=confirm&nv=5f6308a4acee11ed40a4a2771d157e7b

    Plugin Author Brian Mutende

    (@picocodes)

    Hello guys, the issue with the confirmation link was fixed. We’re currently testing the other changes that we’ve made to the plugin before we release it.

    A quick fix is to set a custom page where subscribers should be redirected to after they confirm their emails.

    This can be done inside the plugin settings page on the Pages section.

    Thread Starter ohgoodiee

    (@ohgoodiee)

    Awesome! Thank you for the reply. I really do like the simplicity/lightweight of this plug-in.

    I’ll give the custom page a try

    Plugin Author Brian Mutende

    (@picocodes)

    @ohgoodiee you’re welcome. Do let me know if you encounter any other issues that should be resolved in the next release.

    Thread Starter ohgoodiee

    (@ohgoodiee)

    Putting [about] in the redirect page worked.

    An oddity that I ran into is on the email form. I set the fields ‘name’ and ’email’ and used the widget that was supplied by the plug-in to show on the main page, but it only shows the ’email’ field and not the ‘name’ field.

    Plugin Author Brian Mutende

    (@picocodes)

    Are you using the “Noptin New Form” widget or the “Noptin Premade Form” widget?

    Thread Starter ohgoodiee

    (@ohgoodiee)

    New form.

    The premade doesn’t show up on the home page

    Plugin Author Brian Mutende

    (@picocodes)

    The new form widget is meant to be used if you need to quickly make a form and add it to a widget area. In addition, it only displays email fields.

    Forms created using the optin editor can only be added to your site via the “Premade form” widget.

    If it doesn’t show up then you might have forgotten to publish the form, or you did not select the correct form while setting up the widget or you have set up the widget to only show up on specific pages.

    1. Check to see if the form is published.
    2. Open the form and ensure that is set to display everywhere. This option is found in the display options panel of the settings tab.

    Let me know if all the above don’t work so that I can think of other alternatives.

    Thread Starter ohgoodiee

    (@ohgoodiee)

    On the money. Thank you for the reply. I’ll try creating a form and using the premade widget.

    Thread Starter ohgoodiee

    (@ohgoodiee)

    Hi Brian, quick update.

    Everything is working like a charm.

    One feature request. A checkbox in the admin area to disable emails being sent when a post is updated.

    I had noticed a couple of my post had misspelled words. After correcting them, it had sent new emails to the subscribers.

    Thanks much

    Plugin Author Brian Mutende

    (@picocodes)

    I don’t get you quite clearly.

    Is it sending duplicate notifications for a single post or is it sending new notifications for old posts?

    Thread Starter ohgoodiee

    (@ohgoodiee)

    Sorry. I’ve been up to long

    So the scenario would be:

    I have a bunch of existing post.

    I get some subscribers.

    I edit some of the existing post (fix spelling errors) after the new subscribers.

    The system sends them emails as if it were a new post.

    Thread Starter ohgoodiee

    (@ohgoodiee)

    Hello all. A big Thank You for the update.

    I do have a suggestion for a future release.

    Scenario: A subscriber signs up with the name abcde and an email address of abcde@abcde.com.

    Anybody can come along and input the same email address with a different name and it will change the name in the subscribers list. It didn’t send out a new email, just changed the name and made that subscriber inactive.

    Can we add the functionality to check to see if an existing email address is already subscribed?

    I would leave the message “thanks for subscribing” in place just to keep the script kiddies at bay.

    • This reply was modified 10 months, 1 week ago by ohgoodiee.
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Confirmation link not working’ is closed to new replies.