WordPress.org

Support

Support » Plugins and Hacks » WP Email Capture » [Resolved] Confirmation emails not being sent

[Resolved] Confirmation emails not being sent

  • Hi there! I am having an issue with confirmation emails not being sent. It was working fine in my localhost MAMP setup, however the emails are not being sent from my live site with my web host. Of course, I suspect the issue has something to do with my web host, and I plan to contact them, but I am not sure what I should tell them. What are the settings or privileges in myPHP that need to be set to get this working correctly? Or am I completely off course in my thinking?

    Thanks for any help
    -Troy

    https://wordpress.org/plugins/wp-email-capture/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rhys Wynne

    @rhyswynne

    Hi Troy,

    No you are not too far off. I believe it’s the php mail() function that may be enabled/disabled. Ask them about it. It should be switched on.

    Alternatively, if you are still having issues, run the plugin through WP Mail SMTP.

    Hope that helps!

    Rhys

    Hi Rhys, thanks for the advice. After further investigation, I discovered that the emails were in fact being sent, however they are for some reason being flagged and blocked by major servers like gmail and hotmail. See message below:

    173.194.68.27 failed after I sent the message.
    Remote host said: 550-5.7.1 [204.232.255.226 1] Our system has detected an unusual rate of
    550-5.7.1 unsolicited mail originating from your IP address. To protect our
    550-5.7.1 users from spam, mail sent from your IP address has been blocked.
    550-5.7.1 Please visit http://www.google.com/mail/help/bulk_mail.html to review
    550 5.7.1 our Bulk Email Senders Guidelines. u4si7226786qat.188 – gsmtp

    — Below this line is a copy of the message.

    This is a brand new address that I just created yesterday and the only mail that it has sent has been to myself. I have my web host working on it.

    I’m interested in the alternative your proposed though, I have the WP Mail SMTP plugin installed and activated, maybe I’ll test it with a gmail address instead of the one that is bouncing back. Is there anything special that I need to configure in the WP Email Capture plugin in order to use it with WP Mail SMTP?

    Thanks for you help!

    -T

    Plugin Author Rhys Wynne

    @rhyswynne

    Hi,

    That’s odd. That is more of a hosting issue more than a plugin issue. What is the email address you are sending it through? That could be an issue.

    Had a play on my server and email gets through fine, so not sure that the plugin is at fault here. WP Mail SMTP just needs to be set up, rather than anything special. All email will be sent via SMTP.

    Hope that helps

    Rhys

    Thanks. The email address is one set up with my hosting plan and therefore has the same domain as the site. I only discovered the bounce backs after setting up and logging into the Horde system. Yeah, I don’t think it has anything to do with the plugin either, other than the possibility that I set it up wrong, but I don’t think that I did because it worked fine with MAMP. I’ll just wait for the web host to get back to me. Thanks for your help.

    Interestingly, I just tried using the plugin using the email address that the plugin is sending from (therefore, to myself) and the email went through fine. It is definitely an IP address blocking issue.

    Plugin Author Rhys Wynne

    @rhyswynne

    Hi Troy,

    Good to hear that – at least you now know where the issue is and it’s **relatively** easy to fix. Let me know when you get it all sorted.

    Thanks for the kind words. Always nice getting even thanked for helping here :).

    Rhys

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Confirmation emails not being sent’ is closed to new replies.
Skip to toolbar