Support » Plugin: Easy Sign Up » Confirmation email not working

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Greenweb


    Hi graphicvisions, sorry about the delay in getting to this topic.

    If you’re on a localhost (testing your site locally on your computer as opposed to on a web server) this may be your problem.

    Is your WordPress website able to send system emails, ie Password, New User or Comments etc.

    I’ll include a few links to similar questions that may have an answer in them for you.

    I hope this helps if not feel free to contact me directly and we’ll work on this issue together. Click my name for my info.

    Plugin Author Greenweb


    I have also found that for some people changing the From email in the setting worked for them.

    Thank you for the reply.
    The site is live – not on a local server. I confirmed that emails are being sent from WordPress (set up a new test user) – and also as I said I get the email notices that someone signed up, just not the Thank You.

    I tried changing the from address (it’s my client’s aol address) to a different address (my own as webmaster) but still didn’t work.

    I looked at the similar questions but am not seeing anything to try.

    Any other suggestions?

    Plugin Author Greenweb


    The plugin does nothing fancy when it generates an Email. It uses WordPress’ own Email function. Which you have confirmed works.

    Similar problems have usually come down to a misconfiguration in the settings; or a typo in the from Email address. This is why I asked you to change out the from Email in the Easy Sign Up Options.

    My next steps in troubleshooting this would be to disable all the other plugins and switch to the default WordPress theme. Then run a test sign up, if it works then there is a conflict with between Easy Sign Up and another plugin or theme. To find out which one you’d need to turn on the plugins one by one.

    Finally, if all else fails I’d be happy to jump into your admin area and take a peek.

    Follow up – I only have 2 other plugins in my site, and didn’t get a chance to try trouble solving as you suggested, but I went ahead and created a quick Thank You Page on the site so people would know the form went through, and once I had that set up I changed the Notification email to my client’s address (vs mine as webmaster), and did a test – and this time it worked!

    Wish I could say how it got fixed – but at least it did.
    Thank you!

    Plugin Author Greenweb


    perhaps not having a thank you page was your problem.

    Hey, I marked this “Resolved” but now have another issue – related. I created a “Thank You” Page – but now that’s not working – submit just keeps people on the home page – which is what I had entered originally. On the Easy Sign-up Options page – I type in the correct URL to the thank you – but it’s not accepting the change.

    Any ideas how to fix?

    I tried deleting the URL, hit “Save Changes” – so it would be blank, and the main URL keeps reappearing. I tried the full URL, just the page, and also the shortlink. None work.

    Even in the email notifications I get, it just shows the original main URL not the thank You Page.

    Plugin Author Greenweb


    No idea what is stopping you from saving the options to the database.
    Are you able to save other changes to that options page?
    Are there any JS errors you can locate via the browser’s developer tools?
    Have you added the http://etc ?
    Have you tried disabling your other plugins (Theme) to see if one of them is the root of the issue?

    Hope these suggestions help.

    If everything above fails to work for you; let’s open a separate topic and if you’d like a more direct help I’ll need access to the site.

    Fixed it – Thanks for your prompt reply – however, it turned out that I had added some code (That I found in another help forum thread) into my widget area so that I could customize the text and have full name and no phone number and that had included a hard-coded URL to my main page.

    [easy_sign_up title=”Sign up to receive our
    Class Schedule” phone=”0″ fnln=”0″ esu_label=”Schedule Signup” esu_class=”emailsignup” esu_r_url=””]

    Just in case this helps anyone else.

    Plugin Author Greenweb


    Thanks for the update! Happy that you found your solution.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Confirmation email not working’ is closed to new replies.