WordPress.org

Support

Support » Plugins and Hacks » WP SVG Icons » [Resolved] Confilic with Font Awesome plugin

[Resolved] Confilic with Font Awesome plugin

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Evan Herman

    @eherman24

    I am fairly certain the conflict arises because the ‘Font-Awesome’ plugin uses unicode that are also declared within my plugin.

    One work around would be to go through the entire plugin and change each icons Unicode to something else.

    I will have a look at this and see if I can come up with a resolution. Sorry you are encountering a problem running the two. I will do my best to get the issue resolved by the end of the day, and will post back here when it is.

    Thank you for pointing out this major issue.

    Evan

    Plugin Author Evan Herman

    @eherman24

    I just downloaded the ‘Font Awesome’ (from http://wordpress.org/plugins/font-awesome/) plugin and I have just installed and activated it on a fresh WordPress install on a 2013 theme.

    Using the ‘Font-Awesome’ dropdown inside of new posts, I was not able to get any icons displaying.

    But using the provided short codes that come with that plugin I was able to get the icons to display properly.

    Example: [icon name=icon-pencil]

    If you use the above method to include ‘Font-Awesome’ icons, and then use my plugin to include more icons you will have no issue.

    I was able to have both plugins active and displaying icons properly as intended, using the following code:
    [icon name=icon-pencil]<span data-icon=""></span>

    The first icon is a font-awesome icon. The second is an icon from my plugin.

    Ultimately the problem lies in the ‘Font-Awesome’ plugin and the way you are choosing to display their icons. Hopefully I was able to help you out and resolve your issue.

    -Evan

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Confilic with Font Awesome plugin’ is closed to new replies.
Skip to toolbar