Support » Plugin: WooCommerce PagSeguro » Configuring PasSeguro the right way

  • Resolved dionysius1989

    (@dionysius1989)


    Hi there,

    Thank you for this amazing plugin and the work you put into it!

    I have a question in relation with the configuration, it is still a bit unclear how I should set the settings in PagSeguro in order for it to work correctly.

    As you might now there are quite some features and I can imagine it’s quite fragile. Right now I have the following

    1. Página de redirecionamento -> All off
    2. Token de segurança -> Put in the woocommerce settings page
    3. Pagamentos via API -> 0n
    4. Notificação de transações -> Off
    5. Retorno automático de dados -> Off

    Are these the right settings in order for the plugin to work correctly? Or should I change some?

    Thank you so much for your time.

    Kind Regards,

    Dion

    http://wordpress.org/plugins/woocommerce-pagseguro/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Claudio Sanches

    (@claudiosanches)

    Just follow the installation guide: http://wordpress.org/plugins/woocommerce-pagseguro/installation/
    It was not written for nothing!

    Especially because with the Token and “Pagamentos via API” enabled, PagSeguro other settings will be overwritten by the plugin. So it does not matter how you configure them.

    Hi Claudio,

    Thank you for your fast reply. I followed the guide exactly as you mentioned.

    My customers transactions stay on “pendente” and it seems that they are not going through.

    The log is very short on it. For example one customer who stayed on “pendente” the only thing I can see back is the following:

    01-16-2014 @ 03:33:26 – Requesting token for order #345 with the following data: <?xml version=”1.0″ encoding=”utf-8″ standalone=”yes”?>
    <checkout><currency>BRL</currency><reference><![CDATA[WC-345]]></reference><sender><name><![CDATA[Victória XXXXX]]></name><email><![CDATA[vick_XXXXXX@hotmail.com]]></email><phone><areaCode>43</areaCode><number>96137881</number></phone></sender><shipping><type>3</type><address><street><![CDATA[Rua Paranaguá 803]]></street><complement><![CDATA[Apartamento XX]]></complement><postalCode>860200XX</postalCode><city><![CDATA[Londrina]]></city><state>PR</state><country>BRA</country></address></shipping><items><item><id>1</id><description><![CDATA[Order #345 – Kit 3 em 1 universal x 1]]></description><amount>75.00</amount><quantity>1</quantity></item></items><redirectURL><![CDATA[http://www.lenteparacelular.com.br/checkout/order-received/?order=345&key=order_52d753069cbXX]]></redirectURL><notificationURL><![CDATA[http://www.lenteparacelular.com.br/?wc-api=WC_PagSeguro_Gateway]]></notificationURL><maxUses>1</maxUses><maxAge>120</maxAge></checkout>

    01-16-2014 @ 03:33:28 – PagSeguro Payment Token created with success! The Token is: 58EC8E09E8E868DFF492FFB91F11XXXX

    IS there something obvious which is causing all the customers to stay on the state of “pendente”?

    Kind Regards

    Dion

    Hi Claudio,

    Thank you for your fast reply. I followed the guide exactly as you mentioned.

    My customers transactions stay on “pendente” and it seems that they are not going through.

    The log is very short on it. For example one customer who stayed on “pendente” the only thing I can see back is the following:

    01-16-2014 @ 03:33:26 - Requesting token for order #345 with the following data: <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <checkout><currency>BRL</currency><reference><![CDATA[WC-345]]></reference><sender><name><![CDATA[Victória XXXXX]]></name><email><![CDATA[vick_XXXXXX@hotmail.com]]></email><phone><areaCode>43</areaCode><number>96137881</number></phone></sender><shipping><type>3</type><address><street><![CDATA[Rua Paranaguá 803]]></street><complement><![CDATA[Apartamento XX]]></complement><postalCode>860200XX</postalCode><city><![CDATA[Londrina]]></city><state>PR</state><country>BRA</country></address></shipping><items><item><id>1</id><description><![CDATA[Order #345 - Kit 3 em 1 universal x 1]]></description><amount>75.00</amount><quantity>1</quantity></item></items><redirectURL><![CDATA[http://www.lenteparacelular.com.br/checkout/order-received/?order=345&key=order_52d753069cbXX]]></redirectURL><notificationURL><![CDATA[http://www.lenteparacelular.com.br/?wc-api=WC_PagSeguro_Gateway]]></notificationURL><maxUses>1</maxUses><maxAge>120</maxAge></checkout>

    01-16-2014 @ 03:33:28 – PagSeguro Payment Token created with success! The Token is: 58EC8E09E8E868DFF492FFB91F11XXXX

    IS there something obvious which is causing all the customers to stay on the state of “pendente”?

    Kind Regards

    Dion

    Plugin Author Claudio Sanches

    (@claudiosanches)

    This pending because only generated a billet in PagSeguro or left PagSeguro when it arrived.

    Some note was added in order?

    I’m facing exactly the same issue. Log content is Dion’s identical.

    Payment is approved, customer is redirected back, but all orders remain as “pendente”.

    My configuration is according to guide (http://wordpress.org/plugins/woocommerce-pagseguro/installation/ -> Just API and token setup, disabled everything else).

    I’m running WP 3.9.1, PagSeguro Plugin 2.3.0 and WooCommerce 2.1.9 (the same issue occurred with previous WooCommerce, PagSeguro and WordPress versions).

    Can you help me?

    Plugin Author Claudio Sanches

    (@claudiosanches)

    @mralisson please, create you own topic and I’ll help you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Configuring PasSeguro the right way’ is closed to new replies.