Support » Plugin: Wordfence Security - Firewall & Malware Scan » Configured but not valid

  • Resolved MJin

    (@koajoa)


    Hi, I’m getting this error on the Diagnostics page of WordFence “CF-Connecting-IP – Configured but not valid” and I’m using CloudFlare. Please advise.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support wfphil

    (@wfphil)

    Hi,

    I would like to have a look at your Wordfence diagnostics report. Please go to the top of the “Diagnostics” tab on the Wordfence “Tools” page. There will be a “SEND REPORT BY EMAIL” button to send the diagnostics report. Enter wftest [at] wordfence [dot] com as the email and @koajoa as the forum username please.

    Once you have emailed me the diagnostics report can you reply here to let me know that it has been sent. This is important in the unlikely event that your installation of WordPress is having an issue with sending mail.

    MJin

    (@koajoa)

    Hi,

    It seems everyday WordFence is asking me to configure the WordFence and I always have to download .htaccess and users.ini file to configure. But back to the original issue, WordFence selected X-Real-IP instead of CF-Connecting-IP, which was giving me an issue. I think it may have something to do with Cloudways “Bot Protection” that I enabled. I’ve also enabled HTTP/3 (with QUIC), 0-RTT Connection Resumption on CloudFlares. But other than CloudFlare setting, I’m suspecting it’s because of Cloudways Bot Protection which I enabled couple of days ago. Everything works as normal now though with X-Real-IP setting.

    Plugin Support wfphil

    (@wfphil)

    Hi @koajoa

    Please find your IP address in this link below – note that this detection is not always 100% accurate on cell phone network internet connections:

    https://www.whatsmyip.org/

    Does your IP address match the IP address shown on the line Your IP with this setting in the General Wordfence Options section on the Wordfence All Options page?

    I see that there is a wordfence-waf.php file present and the auto_prepend_file PHP directive is set process this file.

    There are some lines in the PHP variables section missing from the server phpinfo output in your diagnostics report. If you are getting the notice to “To make your site as secure as possible, take a moment to optimize the Wordfence Web Application Firewall” then the most likely cause is that the .user.ini file is not working recursively and Cloudways can check this for you. A common cause for this is a misconfiguration on the server.

    @wfphil I’ve actually figured out and fixed the issue while awaiting your response. Now it’s working fine. Thank you. 🙂

    Plugin Support wfphil

    (@wfphil)

    Hi @koajoa

    Thank you for the update.

    Hi @koajoa, i am in that same boat (with Cloudways Bot Protection activated and Cloudflare). How did you solved the issue?

    Kind regards.

    @talesg I just turned off Cloudways Bot Protection.

    @koajoa Ok, thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.