Support » Plugin: amr users » Configure list: fallback to list #1

  • Hi,
    I am not sure if this is a bug or if it is meant like that:
    when I want to configure a list and change the tab (ie from “Fields” to “Include/Exclude” the list always leaps back to list #1. That means I have to change the tab and then once again have to choose the list I want to configure.
    Can I change that?
    Thanks
    Klaus

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author anmari

    (@anmari)

    Sounds bug like. How annoying.
    I’m not able to look at code for 24-48 hrs.

    A workaround you could try is – always configure list 1, then when done, copy it
    – that way your ‘in progress’ list is always list 1.

    (Big update coming through soon – getting rid of cache and adding new features. Ill double check that aspect.)

    No problem, take your time, great plugin.
    Klaus

    Hi,

    I think that i have some like the same problem.

    When i change a user list and click on update (or rename the list). Then nothing happend on the fronend or in the list view on the backend.
    It seems like copying the last list over and over again.
    Can you help me out?

    Tkx.
    Gr,
    Michael

    I’m afraid I’m having the same problem. If I choose a list, then configure it, the changes are made to ‘list 1’, not the list I was editing. This occurs regardless of which list I select to change

    Workaround:

    – choose Tab you want to edit (i.e. Include/exclude)
    – then choose list and click “select”

    This way I can still edit any list.

    Klaus

    Thanks Klaus but I’m afraid that doesn’t help, If I (for example) select ‘edit headings’ and then select the list I want to edit, the changes I make are saved to ‘list 1’. So: If I have a field in my selected list with a display order of 20 and I edit that field’s heading then save, then what is altered is any field with a corresponding display order in list one.

    Hopefully, the update Anmari mentions above will resolve matters.

    You are right, I had that problem as well with “edit headings”. But for me it worked with the features on separate tabs.
    Regards
    Klaus

    Plugin Author anmari

    (@anmari)

    HI all, the latest small update should help. There’s a delay in the non cache update (unrelated matters) so I decided to see if I could sort this out in the interim.

    Thanks, I will try it out and report back.

    Hmmm. Still no luck. If I alter a heading in ‘list-3’ and then save, the change is reflected in list-1 (but is not applied to list-3). I’ve tried resetting the column headings prior to making a change, but this didn’t help. Maybe, as a stop-gap, I could make changes directly within MySQL tables? Usually, when things go wrong, it turns out to be ‘user-error’. I have not yet ruled that out 🙂

    Plugin Author anmari

    (@anmari)

    HI Michael,
    I apologise about that. It’s weird – I can get some ‘headings’ changes to ‘stick’ to other lists (make sure you rebuild cache), but it did at first seem like something wasn’t right.

    Generally one should rather use nice names to avoid confusion if one configure new colmns but forget to change headings. Headings are only if one needs to have a field called different things in different lists.

    I am loath to ‘debug’ that as the code will eventually be overwritten by the new version I’m working on, so I’m hoping you can work with “nice names” for now.

    michael walker

    (@michael-walker)

    Sure – no problem. Thanks for looking into it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Configure list: fallback to list #1’ is closed to new replies.