Support » Plugin: Mailjet Email Newsletter Marketing » Configure From Name

  • Resolved aand33

    (@aand33)


    Hi,

    I’m using your plugin in my WordPress website.

    And I use it to send email.

    But emails received was from : Root User myemailaddress@mydomain.com.

    I’ve tried to override this by using filters wp_mail_from_name and wp_mail_from. Or by overriding headers in wp_mail call. But nothing was working.

    I’ve looked at your plugin code. In phpmailer_init_smtp() (in mailjet-class.php), the “from” was init like this :

    $phpmailer->From = $from_email;

    So only the email set in the plugin settings was used. There was no from name.

    I’ve replaced this line by :

    $phpmailer->setFrom($from_email, get_bloginfo('name'));

    And now, emails received are from : My website name myemailaddress@mydomain.com

    It would be great to have an input to configure the from name in your plugin settings. And if it’s not set, to use blog name by default.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mailjet

    (@mailjet)

    Hello,

    Thanks for using Mailjet and sending us feedback. We will definitely put this request on our features request list and will add it in a next version.

    Best regards,
    Mailjet Plugins Team

    This was 4 months ago. All my emails get sent with a WordPress myemail@email.com address. It would be easier you just allowed us to set the from name using function

    wpb_sender_name( $original_email_from ) {
        return 'My Name';
    }
    • This reply was modified 1 year, 9 months ago by naresh11381.

    Hi,

    I agree that if we have a field in plugin’s options page to manage the email from attribute, we should have an extra one with email from name.

    Hi,

    Did you get a chance to have a look at this ticket? So far we still need to add an extra plugin a add some code to customize the email from name.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Configure From Name’ is closed to new replies.