Support » Plugin: WP Super Cache » Config file errors on activate

  • I’m getting these errors when I try to activate. I’ve installed via WP and manually using the zip file. Happens either way. I also changed CHMOD on WP-content to 777, still no joy.

    Error: Configuration file /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-content/wp-cache-config.php is missing. Please reload the page.

    Warning! Could not update /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-config.php! WPCACHEHOME must be set in config file.

    Warning! /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-content/advanced-cache.php does not exist or cannot be updated.

    If it already exists, please delete the file first.
    Make /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-content writable using the chmod command through your ftp or server software. (chmod 777 /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-content) and refresh this page. This is only a temporary measure and you’ll have to make it read only afterwards again. (Change 777 to 755 in the previous command)
    Refresh this page to update /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-content/advanced-cache.php

    If that doesn’t work, make sure the file /var/sites/e/edenfloraldesigns.co.uk/public_html/wp-content/advanced-cache.php doesn’t exist:

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m getting these errors too

    @purplenaartjie dale permisos de escritura al wp-config.php ,despues activalo y en panel de administración , y luego vuelve a poner los permisos de antes por medida de seguridad

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    I’m sorry. I don’t know how that would happen if you’ve made wp-content 777. That should make it writeable by all processes. Did you server have any extra security features to limit writes to the same owner perhaps?

    abhinavjain

    (@abhinavjain)

    Hi Donncha, I am getting the same error. I am on wordpress 5.3.1 and (hosted on yunohost system). I tried both the chmod 777 as well as chmod 660 for wp-config.php but it continues to give error. I tried on another instance running WordPress 5.3.1 on the yunohost and the situation is the same.

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    @abhinavjain – does it show an error about updating wp-config.php too? Is the path to that file correct? Is the path to wp-content correct?

    Do you have WordPress installed in the same place it’s being served from? (for example, index.php is in your public_html directory, not a wp directory and symlinks used to load it)

    abhinavjain

    (@abhinavjain)

    Hi Donncha,

    It only shows a warning about updating wp-config.php. The path to file is correct.

    Error: Configuration file /var/www/wordpress/wp-content/wp-cache-config.php is missing. Please reload the page.

    I think there are symlinks involved in my WordPress installation (through yunohost system). I had some writing error while installing Autoptimize as well, but it is working now without a problem once I added the relevant code manually in wp-config.php

    Is there a tutorial on manually adding the files (and code in wp-config.php)? That might resolve the issue?

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    I think you’ll run into problems even with the right constants added to wp-config.php but here’s what you need:

    define(‘WP_CACHE’, true);
    define( ‘WPCACHEHOME’, ‘<FULL PATH TO THIS DIRECTORY>/wp-content/plugins/wp-super-cache/’ );

    The settings page loads wp-config.php and wp-cache-config.php to make sure they’re ok and may give a warning.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Config file errors on activate’ is closed to new replies.