• Resolved eWallz

    (@archonic08)


    Hi, using the latest version. Please check my form export below.
    https://pastebin.com/raw/x0Hj2g42

    The email contents for all situation is {all_fields}

    When I set 1 field with conditional display, the form email notification submitted twice, 1 with upload attachement. the other 1 just form data w/o attachment.

    When no conditional display used. Everything all good.

    I have another longer multipage form with many conditional display used. Once submitted, this time it sent only 1 email with the regular form data. Not Working: File upload, file attachment, calculated value.

    • This topic was modified 2 months, 3 weeks ago by eWallz.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Nebu John – WPMU DEV Support

    (@wpmudevsupport14)

    Hi @archonic08,

    I hope you are doing good and thank you for reaching out to us.

    I imported the form that you have shared to a lab site and submitted the form with uploading (upload field displays conditionally) a file but was unable to replicate the issue. I had the email-log plugin active and noticed only one email generated with all fields including the uploaded file.

    Can you please share if there are any specific steps to be followed? Also, if you wouldn’t mind, can you please share the screenshot of emails received so that we can get a better idea about the issue?

    Best Regards,
    Nebu John

    Thread Starter eWallz

    (@archonic08)

    Hi Nebu, can you please test this longer form with multiple conditional fields.
    https://pastebin.com/raw/XpJ1sNYy

    Plugins Activated:
    – ELementor + Pro
    – Rankmath
    – Post SMTP
    – Forminator (latest)

    WP 5.8

    Steps:
    1. Set email notification to include uploaded attachment. Content All Fields.
    2. Fill in the form. Selecting Yes for answer will display upload box to upload file (jpg/pdf)

    Once submitted, in the forminator form submission all attachments (jpg) were included & calculation were recorded. No issues. check https://snipboard.io/wiDERr.jpg

    In my gmail only receive same data but without Attachment/UPload & Calculation value. Please check https://snipboard.io/HlNMCc.jpg (pls ignore the time sent as the website use server timezone while my gmail use local) – Also same output in my Post SMTP log.

    Thread Starter eWallz

    (@archonic08)

    i’m using astra free theme. tested the same form on other server & domain, still same issue.

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @archonic08

    Thank you for the update.

    I was able to replicate the issue using the exported form.

    We escalated it to our developers to verify why it is happening, once we find more information we will let you know.

    Best Regards
    Patrick Freitas

    Thread Starter eWallz

    (@archonic08)

    Great! thanks Patrick. hoping for a quick fix from your side.
    Do older versions can fix this ? while waiting for your team to fix the current version..

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @archonic08

    You can download the previous version ( 1.14.11) from this page:

    https://wordpress.org/plugins/forminator/advanced/

    However, our developers are already looking further on this so I hope soon we will have an update for this thread.

    Best Regards
    Patrick Freitas

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @archonic08 !

    Hope you’re having a good day!

    I will mark this ticket as resolved for now due to no further activity.

    Of course, if you need any additional assistance – we’re here.

    Kind regards,
    Pawel

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.