Support » Plugin: Ultimate Member - User Profile & Membership Plugin » conditional fields don’t work in IE or edge browsers

  • Hello,
    1) I am making a profile form for my members, and noticed that conditional fields work good in chrome but not in Internet explorer or Microsoft edge, is there any explanation for this?
    2)live preview works with all forms except for profile forms?
    3) Is there any documentation about ‘choices callback’, uses and how to? I need to do some nested fields(as in a tree) depending on previous choice,a drop down menu of choices opens in the same field, is that possible?
    note: my website is in Arabic.
    4)Is there any conflicts between UM and ‘elementor builder’ ?

Viewing 10 replies - 1 through 10 (of 10 total)
  • UP

    I have the same problem with conditional filed on IE

    UP
    Same here on a german site without elementor builder, on the registration form.

    I can at least answer question 3. There is very little documentation on ‘choices callback’. I did discover that you have to add a callback function in your functions.php file. See example below. Here is the link where I did find some info.

    https://www.snip2code.com/Snippet/1669213/Example-Callback-function-for-Ultimate-M/

    Sample Code

    function getCities() {

    $cities = [
    “Paris” =>”Paris”,
    “Marseille” => “Marseille”,
    “Lyon” => “Lyon”
    ];

    return $cities;

    }

    I have the same problem. Version 11.0.9600.18793.

    Bump. Same problem.

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @davesegal and @samuelstevens9,

    This is a known issue and we’ve fixed it in the upcoming 2.0 version of the plugin.
    Currently, 2.0 version is in beta, however, we hope to release it soon.
    If you want to try new 2.0 version please feel free to download it on our website
    https://ultimatemember.com/product-update-august/
    Thanks for your patience.

    Regards.

    Hi there,

    What I wanted to find out is if I updated to V2, would my user roles remain the same?

    I have developed custom coding to sync user roles across multisite which is extremely important for restriction purposes and noticed on the notes that user roles have been depreciated.

    Would appreciate some feedback.

    Kind regards,
    Levon

    No one has replied to my comment? Is there any support offered on this?

    Hi @ultimatemembersupport,
    the issue isn’t fixed in the 2.0 version (2.0-beta1). I’ve installed it and I’m suffering the same problem with IE11 (Win10x64), the conditional fields don’t work.

    I’ve configured one field (field 2) to stay hidden if another field (field 1) is empty, but with Internet Explorer field 2 stays hidden although I input some text into field 1. I also tested it the other way, show field 2 if field 1 is not empty, with same result.

    With Chrome it works fine.

    Am I missing something? O_O

    Regards.

    No one has replied to the OP’s question #4: “Is there any conflicts between UM and ‘elementor builder’?” So I have submitted a pre-sales question to that effect. But it would be nice for everyone reading this thread if someone would provide this answer. Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘conditional fields don’t work in IE or edge browsers’ is closed to new replies.