• Resolved DiedeExterkate

    (@diedeexterkate)


    Hi!

    We’ve ran into a dependency version conflict after installing your plugin with Composer. This unfortunately prevents us from using the events calendar.

    The package that is causing issues for us is monolog/monolog, which is locked at version 1.24.0 inside the tribe-common package. We use another package which has monolog/monolog locked at 2.2.0. This causes fatal errors. But this could be any package, not just Monolog.

    A possible solution would be to use vendor prefixing with php-scoper. This can add a prefix to the namespace of all your vendor dependencies, which allows multiple versions of the same packages to be used besides each other. We use the same method in Yoast SEO.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support James Welbes

    (@highprrrr)

    Thanks for that! I’ll pass this on to the devs!

    Hey there! This thread has been inactive for a while so we’re going to go ahead and mark it Resolved. Please feel free to open a new thread if any other questions come up and we’d be happy to help.

    I have encountered this issue as well (specifically conflicts with the old version of monolog). Are there plans to resolve this issue?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Composer dependency conflicts’ is closed to new replies.