• Resolved Betty_

    (@betty_)


    Salve!
    Sto provando il vostro plugin, ma riscontro qualche problema.
    Non mi blocca i cookie di Youtube, e inoltre su una pagina precisa non mi blocca neppure i banner pubblicitari di Google adsense.
    Allego screenshot dove si vede il banner di consenso impostato sul rifiuto totale dei Cookies , ma si continua a vedere la pubblicità e i video.
    Per ora tengo disattivato il vostro plugin e ho riattivato il mio precedente.
    Grazie per il vostro aiuto

    • This topic was modified 9 months, 3 weeks ago by Betty_.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Contributor jarnovos

    (@jarnovos)

    Hi @betty_,

    It mainly depends on how you’ve configured the Complianz plugin on your website, as your settings determine whether those resources will be blocked.

    For YouTube, please check that you have the YouTube integration enabled under Complianz -> Integrations -> Services.

    To block your advertisements, you can indicate that your website uses “advertising cookies to show personalized ads” after which these should also be blocked (Complianz > Wizard > Consent > Services > Does your website use cookies for advertising? > “Yes” > “Are any of your advertising cookies used to show personalized ads? > “Yes”.)

    If you want us to take a look at the behavior when the plugin is enabled on your site, let me know as well.

    Kind regards, Jarno

    Thread Starter Betty_

    (@betty_)

    Ti ringrazio per la risposta @jarnovos, ma tutte queste cose che mi hai consigliato io le avevo già attuate in precedenza, e i video continuo a vederli ugualmente.
    Le pubblicità invece sono bloccate in tutte le pagine, tranne in quella segnalata nel mio primo commento.

    Oltre questi problemi ho cercato di bloccare i cookie di Shinystat e di Supercounter tramite il vostro blocco degli script, ma non ha funzionato… forse sbaglio qualcosa…

    Ho attivato il vostro plugin se volete dare un’occhiata, ma non vorrei tenerlo attivo troppo perchè non funzionante.
    Grazie mille per il vostro aiuto.

    Plugin Contributor jarnovos

    (@jarnovos)

    Hello @betty_,

    It does indeed appear as if the Cookie Blocker is not enabled on the one specific page that you attached, while this seems to be fine on other pages.

    For example; on the page with URL (/wordpress/comprare_pagare/), I see that ShinyStat is blocked before obtaining consent, by your integration in the Script Center; as well as the advertisements.

    So, we would need to find the difference between the page that doesn’t work (/wordpress/2015/07/15/la-famiglia-per-me/) and the ones that do work correctly, as that will likely be the solution.

    Is it possible that you had disabled the Cookie Banner on this specific page, or perhaps a PHP error might occur here?

    Kind regards, Jarno

    Thread Starter Betty_

    (@betty_)

    Ciao @jarnovos,

    No, io non ho disabilitato nulla, perciò non riesco a capire il motivo del perchè in quella specifica pagina Complianz non funziona…

    • This reply was modified 9 months, 3 weeks ago by Betty_.
    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @betty_,

    Please know that I’m glad to assist, but the information I can see by looking at the front-end of your site is somewhat limited (and I haven’t been able to replicate this behavior on any test environment yet, to take a look for myself).

    Could you check if there are any PHP errors being logged, which might be able to affect the Cookie Blocker?

    You can do this by using a plugin such as WP Debugging, visiting the affected page and then checking the log files; to see if these contain any related errors.

    Kind regards, Jarno

    Thread Starter Betty_

    (@betty_)

    Ciao @jarnovos

    Ho scaricato il plugin che mi hai consigliato, e mi dà questo messaggio di errore visualizzato in alto su tutte le pagine del blog. Ora l’ho disattivato!

    Notice: WP_Block_Type_Registry::register was called incorrectly. Block names must contain a namespace prefix. For example: my-plugin/my-block-custom Read Debugging in WordPress for more information. (This message was added in version 5.0.0.) in /web/htdocs/www.baby-flash.com/home/wordpress/wp-includes/functions.php on line 5173

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @betty_,

    That warning should be unrelated indeed.

    I’m not entirely sure why this issue appears on just one of the pages of your website yet: but if you would like us to take a closer look at the behavior; please send us a message via support(at)complianz.io and we would be glad to investigate further.

    Kind regards, Jarno

    Thread Starter Betty_

    (@betty_)

    Grazie per la disponibilità @jarnovos, ho risolto eliminando il blocco-video di wordpress, evidentemente era quello che creava il problema.

    Ho inserito un’immagine al suo posto con un link che porta su Youtube. Non mi piace questa sistemazione, ma non posso fare altro.

    Posso chiederti aiuto riguardo l’altro problema o devo aprire un nuovo argomento?

    Vorrei bloccare i cookie di Shinystat e di Supercounter. Ho provato gli script tramite il vostro blocco degli script, ma non ha funzionato… forse sbaglio qualcosa…

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @betty_,

    We can continue in this same thread, no problem.

    I visited the site once more and it doesn’t look like Complianz is enabled at the moment, so I could not see the way you’ve tried blocking Shinystat or Supercounter at the moment.

    Could you re-enable the plugin and provide a link to a page where we may see these implementations?

    Kind regards, Jarno

    Thread Starter Betty_

    (@betty_)

    Ciao @jarnovos,
    ho riattivato Compliance per farti dare un’occhiata
    Ti allego screenshot per visualizzare Supercounter e Shinystat.
    e gli script che ho implementato nel vostro Plugin. Li puoi vedere in fondo ad ogni pagina del sito.

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @betty_,

    You seem to already have these scripts added on your page, so, in this case you will likely want to use the field Block a script, iframe or plugin, instead of Add a third-party script (under Complianz -> Integrations -> Script Center).

    So, please start by removing those two implementations under “Add a third-party script” (they are called Supercounters, Contatore Shinystat in your screenshot).

    After doing so, navigate to the Block a script, iFrame or Plugin field and use the below configuration to block both of them.

    Thread Starter Betty_

    (@betty_)

    Grande!!! Funziona!!

    Grazie di cuore @jarnovos , per il tuo aiuto e prezioso tempo dedicato a me!

    • This reply was modified 9 months, 3 weeks ago by Betty_.
    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @betty_,

    Glad to hear that works for you, and of course; not a problem at all.

    If you’re happy with the plugin and our support, it would be really great if you could consider casting a review about the plugin here: https://wordpress.org/support/plugin/complianz-gdpr/reviews/#new-post

    Thank you very much in advance. I’ll mark this thread as resolved as well!

    Kind regards, Jarno

    Thread Starter Betty_

    (@betty_)

    Farò sicuramente la recensione e presto passerò al Premium 🙂

    Thread Starter Betty_

    (@betty_)

    Scusami tanto @jarnovos, ho ancora un problema…

    I contatori Supercounter e Shinystat, non dovrebbero visualizzarsi dopo l’accettazione del consenso? Invece non appaiono… non si vedono più!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Complianz non blocca i video e banner Adsense’ is closed to new replies.