Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Complianz doesn´t block vimeo videos

  • Resolved Ivaylo Ivanov

    (@ivaylo-ivanov)


    Hi,

    the Vimeo videos are not blocked via the Complianz plugin.
    Here my setup:
    WordPress 5.7.2
    Complianz 5.2.2
    Theme: Twenty-Twenty-one
    Installed Plugin: only Complianz

    Within the settings for Services Vimeo and YoutTube are activated.
    On one page, where an YouTube and Vimeo video is integrated, only the YouTube video is blocked.
    The Vimeo video is integrated via Gutenberg and an simple video link: https://vimeo.com/206307711

    Any ideas

    Cheers
    Ivaylo

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor jarnovos

    (@jarnovos)

    Hi @ivaylo-ivanov,

    If you embed Vimeo using the Gutenberg block, videos should automatically be embedded privacy-friendly. I can have a look at the URL to see if there are any tracking cookies from Vimeo.

    Kind regards,
    Jarno

    Thread Starter Ivaylo Ivanov

    (@ivaylo-ivanov)

    Hi @jarnovos

    what do you mean with privacy-friendly? No Tracking?
    I would like to block the vimeo iframe when I open the site initially. Just like the youtube video.

    I’m testing on a local environment with a fresh WordPress installation.

    Kind regards,
    Ivaylo

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @ivaylo-ivanov,

    When using the Gutenberg block the plugin should automatically append “&dnt=1” to the Vimeo URL, resulting in the privacy-friendly version of the Vimeo embed.

    Could you try adding the video as an iFrame in a Custom HTML block, to see if it gets blocked? <iframe src="https://player.vimeo.com/video/206307711" width="640" height="360" frameborder="0" allow="autoplay; fullscreen; picture-in-picture" allowfullscreen=""></iframe>

    If it doesn’t, please verify that the Vimeo integration & placeholder are enabled under Complianz > Integrations > Services.

    Kind regards,
    Jarno

    Thread Starter Ivaylo Ivanov

    (@ivaylo-ivanov)

    Hello @jarnovos

    when I use the iFrame then the player gets blocked and I see the placeholder.
    When I add two videos on one page, one via html block and an iFrame, and the another one as direct link, only the iFrame video gets blocked.

    The “&dnt=1” gets correctly added to the frame. But I would like to block the Video and show the placeholder.

    Thanks
    Ivaylo

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    As adding the dnt=1 parameter is default WordPress behaviour, you’ll need to remove it using a wp core hook. Based on this thread,
    https://wordpress.org/support/topic/vimeo-oembed-now-has-dnt1-parameter/
    I expect something like this to work:

    function dl_oembed ( $provider, $url, $args ) {
      if ( strpos( $provider, 'vimeo.com' ) !== false)
        return add_query_arg( array('dnt' => false), $provider );
    }
    add_filter( 'oembed_fetch_url', 'dl_oembed', 10, 3 );

    If you remove it, Complianz will start blocking it.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.