Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Complianz causing problems with Front-End

  • Hello together,

    Complianz is causing problems on some of my pages.

    Content, animations and other stuff are not visible anymore, so they are not working as intended. Strange thing is that they are still there. If you go over it with the mouse the link is there. You just cant see or use it.

    My Website: https://seesis-geldstube.de/

    Example 1 is the Homepage.(https://seesis-geldstube.de/)
    Screenshot 1 (https://ibb.co/r0kmzTW) is showing how it should look like, Screenshot 2 (https://ibb.co/Xp1ftTY) how it looks when Complianz is activated.

    Example 2 (https://seesis-geldstube.de/neu-in-der-stube/)
    Screenshot 3 (https://ibb.co/Gvny8BS) – How it should look like
    Screenshot 4 (https://ibb.co/5nbm3NZ) – How it looks with Complianz

    This fault is just on some pages, others are working fine. Content is working, cookie banner is working. On the Homepage for example, it doesnt.
    At the moment the Plugin is activated. Just write me when i should deactivate it.

    I hope you can help me. Complianz is a very beautiful and easy Plugin and i don´t want to miss it… :/

    Thank you very much in advance!

    Seesi | Phillip

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @seesi,

    Currently I can’t see your homepage, as it’s password protected. Maybe you can remove the password protection so we can take a look.

    It sounds as if there’s a jquery conflict. Possibly the plugin is blocking a script which has dependencies.

    You could try to deactivate the integrations one by one to see if any of the blocked services or plugins are causing the issue.

    Thread Starter Seesi | Phillip

    (@seesi)

    Hi @rogierlankhorst
    thank you for this really fast reply.

    Im sorry, i am still building my Page and often forget the password protection.
    I turned it off!

    Which integrations do you mean?
    The only thing i know at the moment is that it is definitely coming from Complianz.
    Sure i can do more tests!

    Seesi | Phillip

    Plugin Contributor Aert

    (@aahulsebos)

    Hi @seesi,

    Thanks, we will have a look.

    The integrations @rogierlankhorst meant can be found under Complianz > Integrations – either services or plugins that are integrated.

    regards Aert

    Thread Starter Seesi | Phillip

    (@seesi)

    Hi @rogierlankhorst, hi @aahulsebos,

    thank you for your support. I found the problem! 🙂
    As you said, it is an integration. -> Google ReCaptcha

    What is your recommandation to do now?
    Strange thing is that not only my contact form is unvisible, other things like arrows for scrolling e. g. are unvisible too.

    Best regards,

    Seesi | Phillip

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    It looks like your theme is dependent on the recaptcha script. Because Recaptcha is blocked, the script that is dependent in your theme will break.

    What you could try is to block the dependent script as well, by adding this to the script center (second input field)

    /Extra/core/admin/js/recaptcha

    If you still have issues then, please the the browsers developer’s console for script errors, and paste them here.

    We might need to add a dependency to make sure the scripts fire in the correct order.

    Thread Starter Seesi | Phillip

    (@seesi)

    Hi @rogierlankhorst,

    here is my current configuration.

    https://ibb.co/XZBnp1C
    https://ibb.co/Prnp7jT

    Did i add your text correctly?
    Alternatively i tried seesis-geldstube.de/Extra/core/admin/js/recaptcha.
    This didn´t work as well.

    I hope these are all script errors. Im sorry, im pretty new to this whole theme, but i try my best to support you.

    What i did (Using Chrome):
    1. Incognito Mode
    2. CTRL + Shift + J
    3. Pasted the Errors.

    
    2www.googletagmanager.com/gtm.js?id=GTM-N8XNZD9:1 Failed to load resource: the server responded with a status of 404 ()
    Geldstube_gefllt-scaled.jpg:1 Failed to load resource: the server responded with a status of 404 ()
    ebook-03.png:1 Failed to load resource: the server responded with a status of 404 ()
    jquery-migrate.min-1.4.1.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
    scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111 Uncaught ReferenceError: etCore is not defined
        at HTMLDocument.<anonymous> (scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111)
        at i (jquery-1.12.4-wp.js:2)
        at Object.fireWith [as resolveWith] (jquery-1.12.4-wp.js:2)
        at Function.ready (jquery-1.12.4-wp.js:2)
        at HTMLDocument.J (jquery-1.12.4-wp.js:2)
        at HTMLDocument.c (rocket-loader.min.js:1)
        at l (rocket-loader.min.js:1)
        at t.simulateStateAfterDeferScriptsActivation (rocket-loader.min.js:1)
        at Object.callback (rocket-loader.min.js:1)
        at t.run (rocket-loader.min.js:1)
    scripts.unified-aaf13a81e49793495b669f89ddca7089.js:10 Uncaught TypeError: Cannot read property 'hasClass' of undefined
        at Object.init (scripts.unified-aaf13a81e49793495b669f89ddca7089.js:10)
        at scripts.unified-aaf13a81e49793495b669f89ddca7089.js:10
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
        at l (rocket-loader.min.js:1)
        at t.simulateStateAfterDeferScriptsActivation (rocket-loader.min.js:1)
        at Object.callback (rocket-loader.min.js:1)
        at t.run (rocket-loader.min.js:1)
        at rocket-loader.min.js:1
    (index):1 A cookie associated with a cross-site resource at http://bloglovin.com/ was set without the <code>SameSite</code> attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with <code>SameSite=None</code> and <code>Secure</code>. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
    scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111 Uncaught ReferenceError: et_fix_slider_height is not defined
        at scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
    3scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111 Uncaught ReferenceError: et_fix_slider_height is not defined
        at scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
    (anonymous) @ scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111
    dispatch @ jquery-1.12.4-wp.js:3
    r.handle @ jquery-1.12.4-wp.js:3
    c @ rocket-loader.min.js:1
    2scripts.unified-aaf13a81e49793495b669f89ddca7089.js:50 [Intervention] Unable to preventDefault inside passive event listener due to target being treated as passive. See https://www.chromestatus.com/features/6662647093133312
    (anonymous) @ scripts.unified-aaf13a81e49793495b669f89ddca7089.js:50
    c @ rocket-loader.min.js:1
    99scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111 Uncaught ReferenceError: et_fix_slider_height is not defined
        at scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
    (anonymous) @ scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111
    dispatch @ jquery-1.12.4-wp.js:3
    r.handle @ jquery-1.12.4-wp.js:3
    c @ rocket-loader.min.js:1
    4scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111 Uncaught ReferenceError: et_fix_slider_height is not defined
        at scripts.unified-aaf13a81e49793495b669f89ddca7089.js:111
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
    DevTools failed to parse SourceMap: https://seesis-geldstube.de/wp-content/cache/busting/1/wp-content/plugins/bloom-gdpr-overlay-plugin/assets/js/bgop-bloom.min.js.map
    DevTools failed to parse SourceMap: https://seesis-geldstube.de/wp-content/cache/busting/1/wp-content/plugins/bloom-gdpr-overlay-plugin/assets/css/bgop-bloom.min.css.map
    
    • This reply was modified 1 year, 2 months ago by Yui. Reason: please use CODE button for proper formatting
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Hi @seesi,

    I notice you use Tag Manager: this results in the script field not being shown. Can you try the following:
    – disable Tag Manager, two additional fields will appear in the script center
    – add the string to the second field, where you can block scripts (you put it in the “iframes” field)
    – enable Tag Manager again

    Thread Starter Seesi | Phillip

    (@seesi)

    Hi @rogierlankhorst,

    here are the steps i did.

    1. Deactivated the Statistic Tracking Option in the Complianz Guide (https://ibb.co/5FkfXmv)
    2. Added the String into both fields (a mistake?)
    (Settings: https://ibb.co/x8QKJTw)
    3. Started the Assistant again
    (https://ibb.co/RCChm0v ; https://ibb.co/4pbp3WK)

    The Plugin is not showed anymore in the Plugins Tab (https://ibb.co/c839kp9)

    It does not work. Im sorry Rogier, i think i have many mistakes myself in here…

    Here are my whole Complianz Settings at the moment, maybe here is the mistake in:

    https://ibb.co/61HhjNQ
    https://ibb.co/rQ4NW6t
    https://ibb.co/t4v8R0w
    https://ibb.co/pZgL2c2
    https://ibb.co/HrBctpk
    https://ibb.co/vPfWHkb
    https://ibb.co/mRHQrfJ
    https://ibb.co/XStHrqt
    https://ibb.co/tp7GJTK
    https://ibb.co/w79Mqz0
    https://ibb.co/4ZnzM1Z
    https://ibb.co/y06NT8P
    https://ibb.co/wQtG9gz

    
    Geldstube_gefllt-scaled.jpg:1 Failed to load resource: the server responded with a status of 404 ()
    ebook-03.png:1 Failed to load resource: the server responded with a status of 404 ()
    jquery-migrate.min-1.4.1.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
    scripts.unified-24fca181ab70248e57d453b2c47113a1.js:111 Uncaught ReferenceError: etCore is not defined
        at HTMLDocument.<anonymous> (scripts.unified-24fca181ab70248e57d453b2c47113a1.js:111)
        at i (jquery-1.12.4-wp.js:2)
        at Object.fireWith [as resolveWith] (jquery-1.12.4-wp.js:2)
        at Function.ready (jquery-1.12.4-wp.js:2)
        at HTMLDocument.J (jquery-1.12.4-wp.js:2)
        at HTMLDocument.c (rocket-loader.min.js:1)
        at l (rocket-loader.min.js:1)
        at t.simulateStateAfterDeferScriptsActivation (rocket-loader.min.js:1)
        at Object.callback (rocket-loader.min.js:1)
        at t.run (rocket-loader.min.js:1)
    scripts.unified-24fca181ab70248e57d453b2c47113a1.js:10 Uncaught TypeError: Cannot read property 'hasClass' of undefined
        at Object.init (scripts.unified-24fca181ab70248e57d453b2c47113a1.js:10)
        at scripts.unified-24fca181ab70248e57d453b2c47113a1.js:10
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
        at l (rocket-loader.min.js:1)
        at t.simulateStateAfterDeferScriptsActivation (rocket-loader.min.js:1)
        at Object.callback (rocket-loader.min.js:1)
        at t.run (rocket-loader.min.js:1)
        at rocket-loader.min.js:1
    gtm.js:1 Failed to load resource: the server responded with a status of 404 ()
    (index):1 A cookie associated with a cross-site resource at http://bloglovin.com/ was set without the <code>SameSite</code> attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with <code>SameSite=None</code> and <code>Secure</code>. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.
    scripts.unified-24fca181ab70248e57d453b2c47113a1.js:111 Uncaught ReferenceError: et_fix_slider_height is not defined
        at scripts.unified-24fca181ab70248e57d453b2c47113a1.js:111
        at dispatch (jquery-1.12.4-wp.js:3)
        at r.handle (jquery-1.12.4-wp.js:3)
        at c (rocket-loader.min.js:1)
    DevTools failed to parse SourceMap: https://seesis-geldstube.de/wp-content/cache/busting/1/wp-content/plugins/bloom-gdpr-overlay-plugin/assets/js/bgop-bloom.min.js.map
    DevTools failed to parse SourceMap: https://seesis-geldstube.de/wp-content/cache/busting/1/wp-content/plugins/bloom-gdpr-overlay-plugin/assets/css/bgop-bloom.min.css.map
    
    • This reply was modified 1 year, 2 months ago by Yui.
    • This reply was modified 1 year, 2 months ago by Yui. Reason: please use CODE button for proper formatting
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Blocking the theme script causes other dependent scripts not to load.

    I think for now, because the theme is written recaptcha dependent scripts, you need to disable the recpatcha integration, and remove any strings from the script center.

    Then your site will work as normal, only reCaptcha is not blocked.

    To get recaptcha blocked before consent, you could request Divi to integrate with the WP consent API, which is a WordPress core proposal that will be merged into core in the near future.

    As Complianz supports the WP Consent API, integration by Divi will resolve the problem.

    Hope this helps!

    Rogier

    Thread Starter Seesi | Phillip

    (@seesi)

    Hi @rogierlankhorst,

    thank you. I will try this!

    Phillip

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Complianz causing problems with Front-End’ is closed to new replies.