Support » Plugin: All In One WP Security & Firewall » Complianz blocked by all-in-one

  • Hello WordPress memebers,

    I use the amazing plugin called Complianz | GDPR/CCPA Cookie Consent which makes my website GDPR-proof however All In One WP Security & Firewall is blocking it.

    The following rule is blocking apparently a script of Complianz: Advanced Character String Filter.
    How can I exclude the script so that I can enable “Advanced Character String Filter” and use the “Complianz” plugin ?

Viewing 5 replies - 16 through 20 (of 20 total)
  • Hi @nesoor @nenesse @wpsolutions @mbrsolution 🙂

    We’re here to help. If we need to do something at our end, please let us know. If we can share the solutions laid out by @wpsolutions in this thread in a quick manual for all users. We’re happy to add this to our documentation.

    As we are not that familiar with your plugin, I hope you can show us the way.

    regards Aert

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    Did you try to implement what the developer mentioned above? Please read below so you understand what I mean.

    2) Copy the advanced characters string rules from your .htaccess files and then disable those rules and customize them via the “custom rules” tab by removing the string which is causing the 403.

    If you do the above you can add the advanced character string rules feature to your security settings under the customization tab.

    Thank you

    Hi,

    If I understand correctly, I have to check 76 RedirectMatch to find which one is causing the problem, right?

    We know which file is blocked and I innocently thought it was easier to remove that problematic file from the scan inside .htaccess but it is surely more complicated than that.

    Well, I’ll checked that when I have a moment to do that.

    Back,

    So I copy all Advanced Characters String rules into customization tab, and I have to comment one rule into SPECIFIC EXPLOITS section, see the code under:

    # SPECIFIC EXPLOITS
    RedirectMatch 403 errors\.					
    #RedirectMatch 403 config\.					
    RedirectMatch 403 include\.					
    RedirectMatch 403 display\.					
    RedirectMatch 403 register\.				
    Redirectmatch 403 password\.				
    RedirectMatch 403 maincore\.				
    RedirectMatch 403 authorize\.				
    Redirectmatch 403 macromates\.				
    RedirectMatch 403 head\_auth\.				
    RedirectMatch 403 submit\_links\.			
    RedirectMatch 403 change\_action\.			
    Redirectmatch 403 com\_facileforms\/		
    RedirectMatch 403 admin\_db\_utilities\.	
    RedirectMatch 403 admin\.webring\.docs\.	
    Redirectmatch 403 Table\/Latest\/index\.

    Now the Complianz cookie banner works.

    • This reply was modified 1 year, 1 month ago by Nenesse. Reason: more details
    Plugin Contributor mbrsolution

    (@mbrsolution)

    That is very good news. Thank you for sharing your solution. I am sure this will help many users out there.

    Well done, enjoy both plugins.

    Kind regards

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘Complianz blocked by all-in-one’ is closed to new replies.