Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Complianz 6.3.2 Bug

  • Resolved navzh

    (@navzh)


    WP 6.0.2
    PHP 8.1.9

    With Complianz version 6.3.2, mismanagement of cookies occurs blocking even access to the administrator panel. I had to rename the Complianz plugin folder so that I could access the administrator panel again.

    The error that is shown to anyone visiting the site is: Warning: foreach() argument must be of type array|object, string given in /home/httpd/vhosts/xxxxx/httpsdocs/wp-content/plugins/complianz-gdpr/class-cookie-blocker.php on line 66

    Enabling safe mode in Complianz’s settings is the only way to buffer the error, but of course doing so does not block cookies before a user accepts or refuses consent.

    Any idea how else to solve it?

    Thank you for your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • scamo

    (@scamo)

    I’ve also noticed a similar issue. Not a direct error, but if I activate Complianz (also 6.3.2) then the login for the front end breaks. I can strangely stay logged in the admin area.

    By “login breaks” I mean I can log in, but then I’m directly logged back out clicking into the next page.

    WP: 5.8.5
    PHP: 8.0

    Scott

    • This reply was modified 3 months ago by scamo.
    • This reply was modified 3 months ago by scamo.
    • This reply was modified 3 months ago by scamo.
    scamo

    (@scamo)

    Ok. Seems we were having server issues (500 errors) and I didn’t realize it and it seems this caused the update to be flaky. I reinstalled the plugin manually and now everything is working as it should.

    Scott

    Thread Starter navzh

    (@navzh)

    I had already tried but strangely the error, persists..

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    We’ve had reports that on some environments there is a php error on line 66 of class-cookieblocker.php.

    This error is caught in this version:
    https://github.com/really-Simple-Plugins/complianz-gdpr

    Let me know if this resolves your issue.

    It will be released soon.

    Thread Starter navzh

    (@navzh)

    I just installed the version you mentioned, and the problem was solved.

    Thanks for the support

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @navzh glad to hear that! It will be released on the repository tomorrow. Thanks for confirming.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.