WordPress.org

Forums

Path
[resolved] Completely remove comments and pingbacks (7 posts)

  1. villarroel
    Member
    Posted 1 year ago #

    Firstly, thanks for this theme, it's great!

    I did a bulk upload using the TurboCSV plugin. I firstly uploaded some pages as Published and notices that they were displaying like posts with comments and trackback options at the bottom. I then noticed that if I create a Draft and then later publish it, this doesn't happen. So, I then bulk uploaded my pages as Drafts and then later bulk published them, but then the comments and trackback option reappeared (example: http://istudyenglishonline.com/english-verb-conjugation/abandon-2/). It's strange, because it actually says that comments are closed but then has a comment box show up.

    My page settings don't show the option to diable these things and I would like to disable all comments and all trackbacks/pingbacks site-wide.

    Could you let me know if there is a safe way to diable all comments, trackbacks and pingbacks across the site?

    Many thanks in advance.

  2. Sami Keijonen
    WordPress-asiantuntija
    Theme Author

    Posted 1 year ago #

    When you edit page in top right corner there is Screen Options tab. Click it and choose Discussion. After that you can disable comments.

  3. villarroel
    Member
    Posted 1 year ago #

    Thanks for the quick response.

    However, as mentioned, this option does not appear. These are the only options that show up under the Screen Options:
    ------
    Categories Page Attributes Featured Image SSB Settings Stylesheet Layout Excerpt Custom Fields Slug Author Revisions WordPress SEO by Yoast Custom Permalink Permalink Alias
    Screen Layout
    Number of Columns: 1 2
    -----

    Even if the option did show up, it would involve editing each page individually, which wouldn't be ideal.

    Is there a way to disable these things on this theme entirely?

    Thanks

  4. Sami Keijonen
    WordPress-asiantuntija
    Theme Author

    Posted 1 year ago #

    It should definitely be there. I'd disable all plugins and check again.

    But if you want to disable comments on all pages I think you can do it with this code.

    add_filter( 'comments_open', 'my_comments_open' );
    
    function my_comments_open( $open ) {
    
    	return is_page() ? false : $open;
    }

    Put it in your child theme functions.php or in a custom plugin. Note that this has nothing to do with a theme you're using.

  5. villarroel
    Member
    Posted 1 year ago #

    Thank you, I wil try disabling my plugins to see if they are causing the issue.

    Thanks also for the code, however I have placed it in the custom CSS (and tried in the child theme separately) and it hasn't changed anything (I deleted cache and still nothing).

    Can you suggets anything else?

    I appreciate your help.

  6. Sami Keijonen
    WordPress-asiantuntija
    Theme Author

    Posted 1 year ago #

    I have placed it in the custom CSS

    Not in custom CSS but in your custom plugin or child theme functions.php.

    --------

    For this theme you can also create a comments-page.php template in your child theme and leave it completely empty.

  7. villarroel
    Member
    Posted 1 year ago #

    Ok great, that sounds like a good option.

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.