WordPress.org

Support

Support » How-To and Troubleshooting » Completely disable text formatting….?

Completely disable text formatting….?

  • Mark Bloomfield
    Member

    @yellowllama

    Hey guys… bit of a higher grade question here, I fear…

    In my WordPress posts I need to have a call to an iFrame that has URL parameters. Something like:

    <iframe src="http://www.site.com/register/index.cfm?rsid=15&bi=269">

    Now it pulls in the iFrame content just fine… The problem is that WordPress renders the & in the URL as & # 0 3 8 ; (without the spacing) and thus makes the URL parameters unusable.

    Is there anyway to COMPLETELY disable the text editing in WordPress. I’m not using the Rich Text Editor. I basically need the input area of wordpress to be a standard text box that doesn’t parse any of the information in it… just renders it ‘as is’…

    I’d appreciate any help in this regard.

Viewing 1 replies (of 1 total)
  • maerk
    Member

    @maerk

    You mean that the ampersands are being escaped into their HTML entity. This is actually a good thing: you should always escape any ‘&’ characters in URLs when you’re writing HTML.

    Imagine you had a url that looked like:

    example.com/index.cfm?var=value&nbsp=anothervalue

    The browser doesn’t know whether you mean that there is a variable called ‘nbsp’ or whether you want a non-breaking space in the URL.

    However:

    example.com/index.cfm?var=value&#38;nbsp=anothervalue

    Now there’s no confusion.

    Have you noticed that it’s not working?

Viewing 1 replies (of 1 total)
  • The topic ‘Completely disable text formatting….?’ is closed to new replies.