Support » Plugin: WooCommerce Address Book » Completely broken for WooCom 4.6.1?

  • Resolved Chad Reitsma

    (@chadreitsma)


    Had this working on a previous version of WooCom, then upgraded to 4.6.1 and everything is broken.

    There is nothing on the Edit Address page, whereas before it listed all the addresses and had the “Add New Address” button.

    I can see it in your code, but it’s wrapped in some conditionals to only show if $type != ”, but $type is empty… I’m not sure what’s up.

    • This topic was modified 7 months, 4 weeks ago by Chad Reitsma.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Matt Harrison

    (@matt-h-1)

    Hi,

    I’m not really sure what would be doing that. Are you maybe overriding the my-address-book.php template in your theme?

    On our demo site https://woo-address-book.hallme.com/

    We are running
    WordPress 5.5.1
    WooCommerce 4.6.1
    WooCommerce Address Book 1.7.5

    And everything works fine in all of our testing.

    If you have any more information of how we can re-produce the issue we can try and help.

    Matt

    Thread Starter Chad Reitsma

    (@chadreitsma)

    Hey Matt,
    Appreciate the quick response! 🙂

    Nope, I’m not overriding the my-address-book.php file in the child theme.

    It seems like something isn’t saving correctly. I can click on “Add new shipping address” and that takes me to the form, after clicking “Add Address” it just refreshes the same page, the url is: /my-account/edit-address/shipping/?address-book=shipping2

    Sometimes it also removes my existing shipping address… I’m really not sure what’s wrong here.

    • This reply was modified 7 months, 4 weeks ago by Chad Reitsma.
    • This reply was modified 7 months, 4 weeks ago by Chad Reitsma.
    Plugin Contributor Matt Harrison

    (@matt-h-1)

    Where it refreshes the page, the first place that I would look is if it is hitting a field validation error that isn’t showing. If it saves successfully, it redirects back to the Address Book page.

    Are you able to reproduce the issue at all on the demo site here? https://woo-address-book.hallme.com/

    Thread Starter Chad Reitsma

    (@chadreitsma)

    It appears that the action update_address_names isn’t even firing, I’ve placed an echo and exit() inside of that function and it never reaches it… I’ll keep digging.

    Thread Starter Chad Reitsma

    (@chadreitsma)

    It’s failing to validate the woocommerce-edit-address-nonce, where is this declared?

    • This reply was modified 7 months, 4 weeks ago by Chad Reitsma.
    Thread Starter Chad Reitsma

    (@chadreitsma)

    Ah, I finally found it. It’s this terrible theme we’re using.

    There was a child template file form-edit-address.php, and that did not contain the nonce — I have no idea why that was stripped out in this child theme. I’ve just removed it and it’s working again.

    Thanks for your help !

    Cheers,
    C.

    • This reply was modified 7 months, 4 weeks ago by Chad Reitsma.
    Plugin Contributor Matt Harrison

    (@matt-h-1)

    Glad to hear that you figured it out!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Completely broken for WooCom 4.6.1?’ is closed to new replies.