Support » Fixing WordPress » Completely Blank *Everything*

  • I have NO idea what’s going on. This happened to me with a beta test install a couple of weeks ago, but I neglected to mention anything at the time because I was too busy.

    This time around, I have successfully upgraded an install to 2.0 (THANKS developers!!). Everything goes smoothly and all is well with the world. THEN all of a sudden I make a change and *Everything* goes blank–like no output of any kind; no errors, no HTML (on the page or in the source)–nothing.

    Check it out:

    The server is running Redhat 9 with Apache 2 and PHP 4.2.2 (I know, I know, I’m in the process of upgrading).

    Last time, the last thing I remember doing was activating Akismet with a key. This time, I was testing out the new upload feature in the “write” dialogue and after I hit enter, the form area went blank and nothing else appeared to happen, so I refreshed the page and it just went blank.

    I’m at a total loss as to how to proceed. Any idea’s would be greatly appreciated!!

Viewing 14 replies - 1 through 14 (of 14 total)
  • BTW I did search, but to no avail. If someone can point me to a thread that deals with this, I’ll apologize profusly for not searching hard enough to find it 🙂

    This seems to be common. See, for example:

    These are threads that contain the symptom description in the title, so there are more.

    Try deactivating all the plugins and see what that does.

    Well, I would, but I don’t have an admin area to do so. Literally *everything* is blank–the admin area too 🙁

    I’m also not utilizing *any* plugin’s. I haven’t activated either the backup or akismet plugins and I’m using the stock template from the brand new install (I deleted *all* of the files from the old install (backed up of course)).

    None of the other threads seem to deal with this issue specifcally–not that I can read. I’m still digging around, but this isn’t just the home page after I’m logged in.

    Moderator James Huff


    Check your MySQL database. The only time that I saw all of my pages go blank was when I had reached the maximum connection limit for my database.

    Did I mention that I was also running the site successfully after the install for several hours? I did a test post and did some config changes and everything went smoothly.

    I’m also using Firefox 1.5 on OSX.4.3 and the same thing happens in Safari and IE on my winblows box.

    The database is fine. This is running on my own dedicated server with very minimal load and all the other sites on it are running fine.

    Thanks for the fast input peoples 🙂

    Moderator James Huff


    As a shot-in-the-dark, try running the upgrade.php script.

    Tried it. Blank. 🙁

    So, I tried repairing the tables, but they all checked out as good and if they were bad, I’d be getting some sort of error anyhow.

    I manually deleted the plugin’s from /wp-content/plugins/.

    The *only* other change I’ve made is to put the javascript in the sidebar, but after manually removing that I’m still no dice.

    I also have a 24 hour old install up here: on the same server that, even after a new (beta) template and hacks to it seems to be working ok.

    I’m going to start messing with it methodically and see if I can replicate the issue.


    So, I went into the Write area on and tried to upload a picture. It tells me that wp-content needs to be writeable, so I chmod 777. I try again and the exact same thing happens.

    This time I notice that it’s created the /wp-content/cache/ directory, so I delete it and I get the site back.

    I go back to transreality and delete /wp-content/cache/ and it’s back now too.

    I saw this in another thread, but I believe it was unresolved. I’ll try to find that thread again and see what’s up.

    Have you tried disabling the cache altogether? There is a line in wp-settings that would achieve that.

    Sorry I didn’t post back on this–been busy. I didn’t, actually, try to disable the cache through wp-settings.php, because I got a new server and I’ve been busy migrating all of my accounts over.

    The new server is running a more modern PHP (4.3.11) and the cache problem no longer exists for me. I would suggest that perhaps this issue effects installations running < 4.3 ?

    I’ll get around to testing this hypothesis in the near future and post back with results–unless someone already has discovered this?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Completely Blank *Everything*’ is closed to new replies.