Support » Plugin: Visualizer: Tables and Charts Manager for WordPress » Compatible with PHP 7.2?

  • Resolved TiKu

    (@tiku)


    Hi,

    Does this plugin work with PHP 7.2? I have a tool that can test the compatibility of WordPress plugins to PHP versions and it reports this plugin as incompatible with PHP 7.2 due to the use of sqlite. Is this a false negative or is there really an issue?

    Regards
    TiKu

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Hardeep Asrani

    (@hardeepasrani)

    Hey there,

    We’re not aware of any incompatibilities with PHP 7.2 as it runs all of our tests with it. It should work just fine.

    Let us know if you face any issues.

    victorkun

    (@victorkun)

    ERRORS and WARNINGS…

    I ran via the WP-CLI
    (via WordPress Tools dashboard, kept getting error : The plugin/theme was skipped as it was too large to scan before the server killed the process.)

    wp –allow-root phpcompat 7.2 –scan=active

    …and got these results :

    **********************************************************************************
    **********************************************************************************
    **********************************************************************************

    Name: Visualizer: Tables and Charts Manager for WordPress (Lite)

    FILE: /var/www/html/dlnr/wp-content/plugins/visualizer/vendor/neitanod/forceutf8/src/ForceUTF8/Encoding.php
    ———————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————–
    306 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ———————————————————————————————————–

    FILE: /var/www/html/dlnr/wp-content/plugins/visualizer/vendor/phpoffice/phpexcel/Classes/PHPExcel/Shared/PCLZip/pclzip.lib.php
    ——————————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    ——————————————————————————————————————————
    4855 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    4885 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    ——————————————————————————————————————————

    FILE: /var/www/html/dlnr/wp-content/plugins/visualizer/vendor/phpoffice/phpexcel/Classes/PHPExcel/Worksheet/AutoFilter/Column.php
    —————————————————————————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 2 LINES
    —————————————————————————————————————————————————————————
    396 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
    398 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
    —————————————————————————————————————————————————————————

    FILE: /var/www/html/dlnr/wp-content/plugins/visualizer/vendor/phpoffice/phpexcel/Classes/PHPExcel/CachedObjectStorage/SQLite.php
    ——————————————————————————————————————————–
    FOUND 9 ERRORS AFFECTING 9 LINES
    ——————————————————————————————————————————–
    56 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    57 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    102 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    136 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    160 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    208 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    235 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    274 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    277 | ERROR | Extension ‘sqlite’ is removed since PHP 5.4
    ——————————————————————————————————————————–

    FILE: /var/www/html/dlnr/wp-content/plugins/visualizer/vendor/phpoffice/phpexcel/Classes/PHPExcel/Autoloader.php
    —————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————-
    8 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    —————————————————————————————————————-
    Update Available: 3.1.3; Current Version: 3.1.2;

    Plugin Contributor Hardeep Asrani

    (@hardeepasrani)

    Hey there,

    Please create a new issue for your question, as per WordPress.org forum guidelines. Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.