WordPress.org

Forums

Simple Local Avatars
Compatibility with WP 3.8.3 (8 posts)

  1. Henry Wright
    Member
    Posted 1 year ago #

    I seem to be having problems with the plugin (2.0) since upgrading to WP 3.8.3. The problem happens after avatar upload - the upload does not complete and the page reloads but stalls before loading the full page HTML (this results in whitespace from half way down my page onwards).

    Then when I visit the User section in WP admin, only a handful of users show up in the list yet the total user count (100s) is about right.

    If I disable the plugin, the problem is resolved. Anyone else seeing this after upgrading to WP 3.8.3?

    https://wordpress.org/plugins/simple-local-avatars/

  2. Henry Wright
    Member
    Posted 1 year ago #

    Update: I'm 95% sure the problem of the page only half loading is a failure to generate the avatar thumb (I'm using get_avatar() on the page with the size set to 30). I've checked the uploads folder and only one file exists (the original full image). There's no 30x30 version as would have been created pre 3.8.3 upgrade.

    Note: I just upgraded to 3.9 and that didn't solve the problem.

  3. Henry Wright
    Member
    Posted 1 year ago #

    Update: I've checked the user meta table in the database and only the value of the full avatar URL is getting recorded to the simple_local_avatar key. So it seems the problem (after narrowing down) is due to the resizing of the images.

  4. Henry Wright
    Member
    Posted 1 year ago #

    Could this be a memory limit thing?

  5. Henry Wright
    Member
    Posted 1 year ago #

    I'm 95% sure this is a memory issue. According to the guys at Stack Overflow ~81mb of memory is needed to resize an image of 5000 x 5000. The resized images didn't appear in /uploads/ because the WP resize engine threw an exception when it reached the memory limit.

    My work around was to filter wp_handle_upload_prefilter and disallow images over a certain size dimension. I used getimagesize() to get the image size if that helps.

  6. Kogle
    Member
    Posted 11 months ago #

    Hi, i don't how to get the rss feeds on my wp/site to work, am not sure either that it had ever worked.Each time i try it says An error has occurred, which probably means the feed is down. Try again later.To this area i so wish to have the feeds about..Business Start-up..will someone please tell me how to do so...i don't have a developer for my site anymore, Please will someone help me with my site because there are some other things do need to put in place...HELP!!

  7. Kogle
    Member
    Posted 11 months ago #

  8. Henry Wright
    Member
    Posted 11 months ago #

    Hi Kogle,

    You sure you're in the right place? This thread is about the Simple Local Avatars plugin. You might want to try the WP Jobs forum?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Simple Local Avatars
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.