Support » Plugin: Random Content » Compatibility with the Latest Version of WordPress

  • Resolved raetheillustrator

    (@raetheillustrator)


    Hello, my favorite plugin (Random Content) isn’t working now that wordpress has been updated and I’m mildly panicking lol. Can we expect a plugin update soon?

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jeremy Green

    (@endocreative)

    Can you give me some more details on what isn’t working now that used to be working?

    Thread Starter raetheillustrator

    (@raetheillustrator)

    Sure, I no longer am able to get random words when the page is refreshed. On each refresh, a new set of words should be generated.

    spelet

    (@spelet)

    The plugin is not working in the new wordpress.
    It displays like this on the site
    [random-content group_id=”5″]
    What is wrong? and how do fix this?

    Plugin Author Jeremy Green

    (@endocreative)

    Hello. I am working on an update for the plugin and will release a new version soon.

    Thread Starter raetheillustrator

    (@raetheillustrator)

    Thank you so much Jeremy, waiting with bated breath

    Hello jeremy we love your plugin but i think we have same problem =) wordpress is update
    and i think your plugin need share button and settings on page screen area editing
    Thanx and we are waiting update 🙂

    Plugin Author Jeremy Green

    (@endocreative)

    Hi all,
    I have pushed an update to the plugin. I have tested it on WP 5.7 and it is working for me. Thanks for your patience.

    Thread Starter raetheillustrator

    (@raetheillustrator)

    Thank you Jeremy [stifling back tears of joy]. I’m about to dive right in.

    Thread Starter raetheillustrator

    (@raetheillustrator)

    @endocreative it doesn’t work for me. Is there any specific configuration (other than the plugin and theme updates) that I should be aware of?

    Plugin Author Jeremy Green

    (@endocreative)

    Are you using WP Engine for hosting, or have any caching plugins enabled?

    Thread Starter raetheillustrator

    (@raetheillustrator)

    I host with Siteground and have no caching plugins enabled. I have noticed that it works when I’m logged into my WP admin console but once I’m logged out and browsing like the general public, it doesn’t work 🙁

    Plugin Author Jeremy Green

    (@endocreative)

    Siteground uses their own caching system. It is turned off when you are logged in, but enabled on the site when you are logged out. That is why you see the behavior that you do.

    https://www.siteground.com/tutorials/wordpress/sg-optimizer/supercacher/

    If the random content is on a specific page, then you can just disable caching for that page.

    Thread Starter raetheillustrator

    (@raetheillustrator)

    OK going to get in on these links you’ve sent, reconfigure and return with a verdict. Thank you so much for taking all of this time to help!

    Thread Starter raetheillustrator

    (@raetheillustrator)

    I’ve excluded the specific pages from dynamic caching and that worked swimmingly. I assumed previously that just manually clearing the cache would be enough. Either way, this adjustment gives me peace of mind and a working “Idea Making Gizmo”. A thousand thank yous over and over again!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.