Support » Plugin: AMP » Compatibility with rehub theme and Elementor with Affliate Egg

  • Resolved zo

    (@zotezo)


    Hi,
    My site was built with Rehub theme with contentegg and affliate egg with Elementor Pro as editor.How to make it full compatible with exact element?

    Thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @zotezo If you are using the Rehub theme I believe it provides its own reader mode AMP templates, although that information seems to be outdated. You can check with the ReHub team in relation to AMP support.

    While Elementor doesn’t seem to support AMP just yet I would suggest adding your input to this GitHub issue.

    Thread Starter zo

    (@zotezo)

    Have there any compatibility issue with custom post type permalink plugins.as after enabling that post type url plugins url structure changed.Also beside reader mode if I select other mode then instead of showimge error it is showing some warning.how to recover from this?

    Thread Starter zo

    (@zotezo)

    Hi,
    Compatibility issue with https://wordpress.org/plugins/custom-post-type-permalinks/ happens. Once enabled custom url not working.

    Also enabled Transitional and Standard mode and for a single post it is showing Review 100 validation issue when I click on them it is showing this error-

    Failed to fetch URL to validate. cURL error 28: Operation timed out after 15001 milliseconds with 0 out of -1 bytes received. Please check your Site Health to verify it can perform loopback requests. If you are stuck, please search the support forum for possible related topics, or otherwise start a new support topic including the error message, the URL to your site, and your active theme/plugins. Please include your Site Health Info.

    How to resolve the issue?
    Thanks,
    zotezo

    Plugin Support James Osborne

    (@jamesosborne)

    @zotezo I haven’t tested the Custom Post Type Permalinks plugin, it may not be compatible. I see you’ve already raised the question on their support forum.

    In transitional and standard mode it’s common you may encounter validation issues if using incompatible plugins or themes. The high number may be as a result of just one plugin, the validation tool should inform you of the source.

    In relation to the loopback requests issue can you share the notice you see in your Site Health info screen?

    @zotezo I’m using this one for editing permalinks and it works well with AMP:

    https://wordpress.org/plugins/permalink-manager/

    Thread Starter zo

    (@zotezo)

    Hi,
    Is it possible to use amp plugins for supported theme for mobile only and for desktop we can use default rehub theme.
    If yes how?
    Thanks,
    Zotezo

    Plugin Support James Osborne

    (@jamesosborne)

    @zotezo Are you looking to redirect all mobile traffic to AMP? This mini plugin can enable that, press the “Download Zip” button and install as you would any other WordPress plugin.

    Disabling AMP on desktop only isn’t supported. It’s unlikely you’ll get much traffic on AMP desktop in reader or transitional mode, with search engines usually directing users to your AMP versions on mobile only.

    Plugin Author Weston Ruter

    (@westonruter)

    @jamesosborne I think you actually mean this amp-mobile-redirection plugin: https://gist.github.com/westonruter/787c875e5ab724808c26014153e46ec6

    There is also now an alternative implementation that should be more reliable: https://github.com/ampproject/amp-wp/issues/2044#issuecomment-580891515

    eeprom_one

    (@eeprom_one)

    hi Weston very nice your work for the Amp plugin.

    Have you thought about doing Amp compatibility with globals page builders like Divi and Elementor?

    best regards from southern spain

    Plugin Author Weston Ruter

    (@westonruter)

    Yes, but AMP-compatibility has to be implemented by the page builders themselves. I’ve chatted a bit with Elementor about this at a WordCamp but that’s about it.

    Otherwise, Gutenberg is fully AMP-compatible out of the box.

    eeprom_one

    (@eeprom_one)

    i appreciatte your answer, i check out Gutenberg and its seem for Free but we need to pay some Premium Features and its not my goal this.(i need at least 10 features running)

    I think about Gutenberg, regarding, is Gutenberg powerfully to bring the ‘wow’ effect to my readers?

    thank you so much Weston for your effor, your work and your attention, really.

    Plugin Author Weston Ruter

    (@westonruter)

    Actually you don’t need Gutenberg at all now since it is just part of WordPress. Then to add more capabilities you can add a block library plugin like Atomic Blocks, which is AMP-compatible. You can also consider using the CoBlocks plugin which is mostly AMP-compatible (see issue).

    eeprom_one

    (@eeprom_one)

    thanks a lot Weston, have a nice coding weeekend 😉

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Compatibility with rehub theme and Elementor with Affliate Egg’ is closed to new replies.