WordPress.org

Forums

EZ Emails
[resolved] Compatibility with Profile Builder (8 posts)

  1. eliboni
    Member
    Posted 1 year ago #

    Hi great plugin!

    I'm using Profile Builder plugin to handle user registration form (and user profile options). Although EZ Emails is enabled and the "Replace WP template" setting is set to Y, the default registration email is still the (ugly) wordpress one.

    How can I better debug what's happening? I'm wondering if Profile Builder is forcing that or...

    Thanks for your help,
    Enrico

    http://wordpress.org/extend/plugins/ez-emails/

  2. eliboni
    Member
    Posted 1 year ago #

    I did some further investigations and it came out that Profile Builder is creating and sending its own email. So I believe this thread could be marked as solved.

    Now, I found the code where Profile Builder is sending the email and my guess is that if I replace the call to its own function (line 471 in profile-builder/functions/email.confirmation.php) with a call to the standard wordpress

    wp_new_user_notification( $user_id, $plaintext_pass )

    then EZ Emails should detect this and send the email with the nice format... right?

    Thanks... or grazie,
    Enrico

  3. luigipulcini
    Member
    Plugin Author

    Posted 1 year ago #

    Hi eliboni,
    thank you for your question (and your answer).

    I used Profile Builder myself on a couple of sites and the compatibility issue between it and EZ Emails is a little harder to fix.

    As you have already noticed, PB defines its own message template.
    If it were only that, it would be easy to give EZ Emails priority in defining the default message.

    But that works only when an administrator create a new user.
    If you, as an administrator, create a new user both you and the user receive the email with the template defined in EZ Emails.

    The problem is that Profile Builder completely redesigns the registration form, allowing you to put it in the front end with a shortcode. When the user signs up using that form, the WordPress notification system is completely bypassed and a totally different function is used in its stead.
    I will try to find a solution to filter that as well.

  4. luigipulcini
    Member
    Plugin Author

    Posted 1 year ago #

    Hi eliboni,
    I have just introduced a new option to apply your own template to ALL the emails sent by WordPress. It is called "Force use of template for all emails".

    A new version 1.3 should show up in the WP repository in a few minutes.

    Even though this new option should solve your issue with Profile Builder, I advise you to check if it works for all the contexts you have in your WP installation. Since this new feature replace ALL the email with your template, you may check carefully whether to activate it or not.

    Let me know if I can mark this topic as resolved.

    Best,
    Luigi.

  5. eliboni
    Member
    Posted 1 year ago #

    Whoops! Many thanks ;)

    It works, however I noticed the following text appearing in the Profile Builder page after the registration, just for few secs before the redirect (I replaced the real domain with mydomain):

    Array ( [sender_name] => mydomain - semplice e unico [sender_email] => info@mydomain.it [replace_template] => on [default_template] => Default [version] => 1.3 [override_all_mails] => 1 ) Array ( [sender_name] => mydomain - semplice e unico [sender_email] => info@mydomain.it [replace_template] => on [default_template] => Default [version] => 1.3 [override_all_mails] => 1 )

    is there any debug still active?

    Enrico

  6. luigipulcini
    Member
    Plugin Author

    Posted 1 year ago #

    Ciao Enrico,
    ho controllato il codice e non mi pare contenesse alcun output di debug a video. Ho comunque aggiornato alla versione 1.3.1, assicurandomi che non ci sia alcuna operazione del genere.
    Tuttavia non ho capito esattamente dov'รจ che questo output ti compare.

    I guess you are Italian, so my previous answer should be fine.
    For all the other users, please update to version 1.3.1 which is surely with no debugging output.

  7. luigipulcini
    Member
    Plugin Author

    Posted 1 year ago #

    With version 1.3.2 this issue should be resolved.
    Let me know.

  8. martin_ziegert
    Member
    Posted 1 year ago #

    Here maybe a different tool for template and content builder by drag and drop http://jb-webs.com/websiteBuilder-Use_Real.html it comes as well with a form builder http://jb-webs.com/websiteBuilder-Contact_Form_Engine.html and works right away out of the box - let me know when you try it how it works for you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.