Support » Plugin: WP eCommerce » Compatibility with PHP7.2 – [] operator not supported for strings

  • madeglobal

    (@madeglobal)


    We’ve tracked an issue we have with our wordpress installation to wp-e-commerce. Basically, after upgrading our server to php7.2 we get errors similar to:
    [] operator not supported for strings

    Without line numbers to figure out where this issue has happened, it is difficult for us to know how to fix the issue.

    Site works fine without wp-e-commerce, but having used it on our shop for many years, we would like to continue to use this plugin! At the moment, nobody can check out.

Viewing 2 replies - 1 through 2 (of 2 total)
  • whitelamp

    (@whitelamp)

    “Without line numbers” – why is that?

    Unless the code for WPEC gets updated, I think we’re going to have to call it a dead plugin. There are multiple incompatibilities throughout the code.

    It’s incredibly sad to have come to the end of the road with this great plugin, but our shop just won’t work at all and though we could go through and fix the individual issues, they of course have the potential to be overwritten and broken again by a subsequent update of the plugin.

    Anyone fancy taking on this plugin and making it PHP7.2+ compatible?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Compatibility with PHP7.2 – [] operator not supported for strings’ is closed to new replies.