Support » Plugin: Revision Control » Compatibility with PHP 7

  • Resolved td7

    (@td7)


    First off, I like this plug-in. Today, I upgraded my site to PHP7 and got an error relating to the plug-in. Once I deactivated the plug-in, the site came back up.

    Given that PHP 7 just came out, I don’t expect many people will encounter this issue so this is more a “heads up”

    https://wordpress.org/plugins/revision-control/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author dd32

    (@dd32)

    Meta Developer

    Thanks for the heads up! Can you let me know exactly what the error message you encounter is?

    I’m unfortunately offline for most of the next week, so won’t be able to test directly with PHP7

    Hi Dion,

    This is what shows in my PHP Error log

    [05-Dec-2015 19:01:55 UTC] PHP Fatal error: ‘break’ not in the ‘loop’ or ‘switch’ context in /home/webmas91/public_html/wp-content/plugins/revision-control/revision-control.php on line 402

    I hope this helps.

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: ‘break’ not in the ‘loop’ or ‘switch’ context in /mnt/weba/d1/53/53706553/htdocs/tieptoep.nl/wp-content/plugins/revision-control/revision-control.php on line 402

    That’s exactly what I got when I upgrade to PHP 7 and reactivated the plugin. Seems like it’s the same problem.
    Just give a shout out if you need more info. πŸ™‚

    Plugin Author dd32

    (@dd32)

    Meta Developer

    Thanks! Confirmed the issue.. kind of surprised that it didn’t break under PHP5 too πŸ™‚ It’s a stupid copy-paste error!

    I’ll get it fixed up soon. Thanks for reporting it!

    Yeah, it worked fine in PHP 5.6, only got the issue after switching over to 7.
    Thanks for the fast response! I’ll look forward to the update and I’ll let you know if I encounter any issues.

    Plugin Author dd32

    (@dd32)

    Meta Developer

    I just pushed Version 2.3.2 which should fix these PHP7 compatibility issues.

    Let me know if you’re still seeing issues.

    Dion,

    I just updated it on one of my PHP 7 sites and it worked fine. Thanks. I’m going to mark this as resolved.

    I’ve also updated and it seems to be running fine for the last two days. Thanks for the fast fix! πŸ™‚

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Compatibility with PHP 7’ is closed to new replies.