Support » Plugin: Tiled Gallery Carousel Without JetPack » Compatibility with PHP 7

  • This plugin is still not fully compatible with PHP 7 as it is using deprecated class constructors (themePacific_jetpack_User_Agent_Info instead of __construct) and therefore emits notices in sensitive environments.

    • This topic was modified 3 years, 1 month ago by repli2dev.
Viewing 3 replies - 1 through 3 (of 3 total)
  • MikepFive

    (@mikepfive)

    Hi,

    ** Excellent Plugin – Functionality WITHOUT all Bloat!! **

    Like @repli2dev I’ve identified the same problem

    Here’s a report generated by SG Optimiser:

    FILE: /home/philli24/public_html/styledbybecci.co.uk/wp-content/plugins/tiled-gallery-carousel-without-jetpack/class.jetpack-user-agent.php
    ——————————————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————-
    99 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————————————————————————————-

    It world be GREAT if this could be fixed in a future release!

    Kind Regards,

    Mike

    Please note that you can solve this issue by this method.

    Plugin Author ThemePacific

    (@raja3c)

    Oops! We’ve missed that one PHP 7 compatability plugin not detected this.
    We’ll fix it

    We’ve checked withour team, this issue has been already fixed in the latest version 3.0.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Compatibility with PHP 7’ is closed to new replies.