Support » Plugin: Quick Paypal Payments » compatibility with php 7.2

  • First of all – love the plugin, thanks! I have been using it on a couple of sites. Unfortunately on one site it stopped working and I’m getting messages like these:

    Notice: Undefined index: reference in /home/xxxx/public_html/wp-content/plugins/quick-paypal-payments/quick-paypal-payments.php on line 653

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/xxxx/public_html/wp-content/plugins/quick-paypal-payments/quick-paypal-payments.php on line 931

    Notice: Undefined index: ruse_stock in /home/xxxxx/public_html/wp-content/plugins/quick-paypal-payments/quick-paypal-payments.php on line 1021

    The host recently updated php to 7.2 so I was wondering if it has anything to do with it. I’m also getting errors with other plugin that also uses paypal. Both plugins are used on another site I have with different host and they both work fine on php.5.6.38

    I’m not a developer, so I’m just trying to guess any correlation. Any help would be greatly appreciated!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi again,
    I switched from php 5.6.38 to 7.2 on the other website (where the plugin worked fine) and the same thing happened – I started getting error messages. So I reverted back.
    Unfortunately the host of the website I’m trying to fix right now doesn’t give me the option, they only use php 7.2
    The plugin seems to be working fine otherwise, I just get bunch of those error messages…

    Hi,

    I have the same issue on my WordPress in multisite mode. I have 2 languages: Fr and en.

    On Fr version, it’s working fine (and always worked fine even on Php 7.2) and on En version I have this same warning

    Any clues?
    Kind regards

    Plugin Author aerin

    (@aerin)

    Disable error reporting and you won’t see the messages.

    Hi,

    This hide the issue. Quick fix for now

    Thanks

    Plugin Author aerin

    (@aerin)

    Yes, it is a quick fix for now as nothing I do fixes the problem.

    I could spend a lot of time rewriting the code but I just don’t have the time. If someone want to do it for me I’ll happily pay them for their time.

    How/where can I hide the error messages?

    Plugin Author aerin

    (@aerin)

    In your wp-config.php set WP_DEBUG to false:

    https://codex.wordpress.org/WP_DEBUG

    Unless you have some other sort of reporting plugin installed in which case just disable it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘compatibility with php 7.2’ is closed to new replies.