Support » Plugin: Stop User Enumeration » Compatibility with PHP 7.0

  • Resolved egladen1

    (@egladen1)


    Hi

    I’ve run a compatibility checker plugin with php 7.0 and the Fullworks WP VPS security (stop user enumeration) is coming up with an error:

    FILE: /nas/content/staging/cyberseer/wp-content/plugins/stop-user-enumeration/freemius/includes/fs-essential-functions.php
    ————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————————–
    172 | WARNING | Function name “__fs” is discouraged; PHP has reserved all method names with a double underscore prefix for future use

    Is this something you’ll be updating in the next plugin release?

    Many thanks
    Liz

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Fullworks

    (@fullworks)

    Hi Liz,

    Thank you for your question.

    The compatibility issue you have identified is only a warning and does not currently stop the plugin operating under PHP 7, in fact all the plugin development is performed under PHP 7.

    However of course, the issue has duly been noted and will be addressed in a future release.

    Alan

    Plugin Author Fullworks

    (@fullworks)

    As it is only a warning, and indeed WordPress itself has a core function __(), and the plugin operates fine in PHP 7 I will close this issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Compatibility with PHP 7.0’ is closed to new replies.