Support » Plugin: Events Manager » Compatibility with PHP 7.0

  • Hi, I am using the latest version of the Event Manager plugin on a site running PHP 5.6, but the hosting company is encouraging us to upgrade to PHP 7.0. I ran a compatibility checker, and unfortunately it came up with the following errors with the plugin. Do you have plans to update the plugin to make it PHP 7.0 compatible?

    /wp-content/plugins/events-manager/em-shortcode.php
    —————————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————————–
    113 | ERROR | ‘clone’ is a reserved keyword introduced in PHP version 5.0 and cannot be invoked as a function (T_CLONE)
    —————————————————————————————————————————–

    /wp-content/plugins/events-manager/classes/em-object.php
    ———————————————————————————————————————————-
    FOUND 1 ERROR AFFECTING 1 LINE
    ———————————————————————————————————————————-
    1177 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    ————————————————————————————–

    wp-content/plugins/events-manager/templates/buddypress/group-events.php
    ————————————————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————————————–
    31 | ERROR | Using ‘break’ outside of a loop or switch structure is invalid and will throw a fatal error since PHP 7.0
    ————————————————————————————————————————————————–

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Compatibility with PHP 7.0’ is closed to new replies.