Support » Theme: Twenty Sixteen » Compatibility with CSS is broken

  • This theme uses “fancy” things that make this plugin awful in my opinion.

    The a elements are supposed to use “text-decoration:underline” but instead use a box-shadow as a border.
    If you have a plugin or functionality that uses non-text a elements, like in a menu with markitup, you will explicitly need to set “box-shadow:none” for these elements, just to be compatible with this theme.
    I would say, if you want an underline, use an underline. Now plugins CSS is broken.

    Also, it uses “box-sizing:border-box” which breaks carefully made sizes for CSS boxes. Every plugin now needs to explicitly set “box-sizing:content-box”, not just for elements, but also for pseudo-elements like “*::before” and “*::after”.

    Please don’t play these fancy tricks in Twenty Seventeen again, I consider them awful.

  • The topic ‘Compatibility with CSS is broken’ is closed to new replies.