Support » Plugin: Page Optimize » Compatibility with Brizy Plugin

  • Resolved viorel

    (@vioreleremia)


    Hi guys,

    I am one of the developers of the plugin brizy. There are a few users on wordpress.com that have trouble using both plugins together.

    The issue is that page optimize break our js in the iframe when the user is trying to edit a page with our editor.
    Unfortunately, I can’t edit server files on wordpress.com but I see you guys had this issue before with divi builder so maybe a quick way to fix our issue is to add the code below next to divi code. I see it in the file page-optimize.php the function page_optimize_bail.
    can we guys fix this together?

    
    if ( class_exists( 'Brizy_Editor' ) && ( isset( $_GET[ Brizy_Editor::prefix( '-edit-iframe' ) ] ) || isset( $_GET[ Brizy_Editor::prefix( '-edit' ) ] ) ) ) {
    	return true;
    }
    

    All The Best,
    Viorel

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andrija Vučinić

    (@aidvu)

    Thanks for the report. Will update in the next few days.

    Thread Starter viorel

    (@vioreleremia)

    Hi Andrija,

    thanks for letting me know

    Regards1

    Plugin Author Andrija Vučinić

    (@aidvu)

    Hmm, I went and tested an out-of-the-box site with page-optimize and Brizy and it works fine.

    Any more info on what is breaking exactly @vioreleremia ?

    Thread Starter viorel

    (@vioreleremia)

    I have tested on wordpress.com accoutnt and the error is not there anymore.
    I don’t remember what it was but something with js files maybe with the concatonations I’m sorry I didn’t save any evidence. I think we had a lot of updates and somehow they started to work together.
    But I installed the plugin on a regular wordpress installation and everything looks very bad http://test.themefuse.com/viorel/ the dashboard also si brocken
    is this plugin suppose to work on regular installations beside wordpress.com?
    The same think is on localhost

    Thread Starter viorel

    (@vioreleremia)

    Ok, I found it
    one of our users has Non-critical script execution set to async and this reminded me that I sent this issue to our javascript devs and they could understand that is happening and besides our issue there are a lot more
    Some of errors here: https://jumpshare.com/v/jl2m2WAmDf1hmDV5y2SW

    Plugin Author Andrija Vučinić

    (@aidvu)

    Ah, it happens when load mode is set to async. Will try to reproduce and apply your fix.

    But I installed the plugin on a regular wordpress installation and everything looks very bad http://test.themefuse.com/viorel/ the dashboard also si brocken
    is this plugin suppose to work on regular installations beside wordpress.com?

    As for this, we have a community PR to make page-optimize work with subdir installations. Currently it only works if the path is the domain. Will probably merge it some time this month.

    Plugin Author Andrija Vučinić

    (@aidvu)

    Pushed page-optimize update (v0.5.1). Closing. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Compatibility with Brizy Plugin’ is closed to new replies.