Support » Plugin: WPFront User Role Editor » Compatibility test PHP 7 gave 4 warnings

  • Good day, i tested my site using this plugin PHP Compatibility Checker and this is what it show.

    FILE: /home/xxxxxx/public_html/wp-content/plugins/wpfront-user-role-editor/classes/base/class-wpfront-options-base.php
    ---------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------
     113 | WARNING | Method name "WPFront_Options_Base::__" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ---------------------------------------------------------------------------------------
    FILE: /home/xxxxxx/public_html/wp-content/plugins/wpfront-user-role-editor/classes/base/class-wpfront-base.php
    ---------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------
     221 | WARNING | Method name "WPFront_Base_URE::__" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ---------------------------------------------------------------------------------------
    FILE: /home/xxxxxx/public_html/wp-content/plugins/wpfront-user-role-editor/classes/base/class-wpfront-base-menu.php
    ---------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------
     211 | WARNING | Method name "WPFront_Base_Menu::__" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ---------------------------------------------------------------------------------------
    FILE: /home/xxxxxx/public_html/wp-content/plugins/wpfront-user-role-editor/classes/class-wpfront-user-role-editor-controller-base.php
    ---------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ---------------------------------------------------------------------------------------
     132 | WARNING | Method name "WPFront_User_Role_Editor_Controller_Base::__" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ---------------------------------------------------------------------------------------

    Is it safe to upgrade PHP version?

  • The topic ‘Compatibility test PHP 7 gave 4 warnings’ is closed to new replies.