Support » Plugin: Freesoul Deactivate Plugins: deactivate plugins on specific pages » compatibility issues with classic editor

  • Resolved Deepak

    (@golinuxcloud)


    Hello,

    Thank you for this amazing plugin.

    The plugin seems to be working fine but I see some issues with classic editor. I am using “Disable Gutenberg” to use classic editor and when I attempt to edit any post then the right sidebar seems to be flapping.

    Ideally it should be fixed while I scroll the edit post section but it keeps flapping and disappearing when I try to scroll up.

    I have created a small screencast video for the behaviour:
    https://imgur.com/a/s878zzy

    Regards

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Jose

    (@giuse)

    Hi @golinuxcloud

    are you talking about this plugin?: https://wordpress.org/plugins/disable-gutenberg/.

    I’ve right now tested it and had no problem on the single page. If it isn’t that plugin, please provide me the link to the right plugin.

    I suggest you the following tests:

    – Go to Freesoul Deactivate Plugins => Custom URLs => Backend URLs and disable all plugins, but keeping active Disable Gutenberg. Use this pattern: *wp-admin/post.php?post=*&action=edit*
    – Check again the same page where you have the issue. If you don’t have it anymore, enable a plugin after the other until you don’t find again the problem.
    – If the previous test gives no useful information, collapse the FDP section on the single page where you have the problem. Maybe it’s not the FDP section that gives the issue, but any section that has a certain height.
    To collapse the section you have to click on the triangle that you see on the top right of the FDP section.
    – Disable FDP and check again the page.

    Let me know the results of your test.

    Thread Starter Deepak

    (@golinuxcloud)

    Thanks Jose for your response and the steps.

    I checked and the conflicting plugin seems to be Jetpack, attached is the screencast of the behaviour with and without jetpack plugin
    https://imgur.com/a/ZDq6VmP

    Just FYI, I have explicitly disabled all the modules of Jetpack and only using
    Publicize
    Contact Form
    Site Stats

    Regards

    Plugin Author Jose

    (@giuse)

    You are welcome.
    It looks the problem is not caused by a conflict with FDP, but by the fact, FDP adds a big section on the single page.
    Try collapsing the section of FDP clicking on the triangle on the top right of the FDP section

    Thread Starter Deepak

    (@golinuxcloud)

    I tried that actually and it didn’t work for me. If you want I can share login credential for my staging site and you can take a look.

    Plugin Author Jose

    (@giuse)

    before taking a look at your staging site there are two things we can still do:
    – You inspect elements, click on Console and check if you have red JavaScript errors
    – I’ll install Jetpack and check if I have the same problem

    Plugin Author Jose

    (@giuse)

    Hi @golinuxcloud

    can you try the beta version 1.8.7.5? It was an unbalanced HTML tag in the previous versions, maybe this was causing the issue in your case.

    You can download the beta version with this link:

    If the direct link doesn’t work, go to https://wordpress.org/plugins/freesoul-deactivate-plugins/advanced/, scroll down until “Please select a specific version to download.”, choose 1.8.7.5 and download it.

    If you prefer to wait until the next official version is public, take into account a few days, I can’t say exactly the right date.

    Thread Starter Deepak

    (@golinuxcloud)

    Thanks @giuse

    I did a quick verification of the development version and it seems to have fixed the issue.

    Again thanks for the amazing plugin and support.

    Regards

    Plugin Author Jose

    (@giuse)

    Perfect @golinuxcloud. You are welcome!

    Thread Starter Deepak

    (@golinuxcloud)

    Hi @giuse,

    Any tentative plan to release the fix or can I use this development version on LIVE website? As it is really annoying that every time I have to scroll my page up to get the right sidebar while writing a new post.

    Regards

    Plugin Author Jose

    (@giuse)

    Hi @golinuxcloud

    The official version will not be ready immediately.

    The beta version 1.8.7.5 should not give problems on your live site,
    On the staging environment, you should have similar conditions, so I don’t think you will have surprises on the live site.

    Remember to deactivate and reactivate the plugin after the update via FTP.

    Thread Starter Deepak

    (@golinuxcloud)

    Thanks for the confirmation.

    Regards

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘compatibility issues with classic editor’ is closed to new replies.