Support » Plugin: Carousel Slider Block » Compatibility issues

  • Hi, very useful solution.
    I found that used in combination with coblocks the Hero Block and some other blocks stop working properly.

    Is it also possible to hook or modify the slick parameters?

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author virgildia

    (@virgildia)

    Hi Roberto. Glad you found the plugin useful!

    I have tested the hero block from Coblocks (latest version: 1.9.4) with the Carousel block on WordPress 5.2 (latest version) and am not seeing any issues. I was able to add hero blocks to the carousel and it displays fine. Could you provide more info? Which plugin and WordPress versions are you using? What specific issue are you seeing? Please note, the carousel slides are just containers for other blocks. The carousel is intended to work with all the core WordPress blocks but cannot account for all third party blocks – they rely on their respective developers and may require some custom CSS.

    You can initiate the slick slide in your own javascript and add parameters. This will require custom coding.

    I am planning to add more carousel options in the next update. Feel free to suggest any carousel options you would like to see the future.

    • This reply was modified 1 month, 2 weeks ago by  virgildia.
    • This reply was modified 1 month, 2 weeks ago by  virgildia.

    Hi!
    WP 5.2 and Coblocks 1.9.4.
    With Carousel block activated i create a new page and I can’t add a new hero block without the block editor completely crashing. With it disabled it works normally. I tried other combinations of plugins and so far its the only problem i can spot.

    On the JS side I tried to initiate the slider by hooking the carousel_block_editor_assets and loading another JS file with no results.
    Can you post an example?

    jQuery(document).ready(function($) {	
    	$('.wp-block-cb-carousel').slick({
    		infinite: true,
    		slidesToShow: 1,
    		slidesToScroll: 1
    	});  
    });

    I would suggest as an option in the panel the infinite rotation and an example of to override the initiation in JS.

    Plugin Author virgildia

    (@virgildia)

    My steps to try and reproduce the issue on WP 5.2 and Coblocks 1.9.4:

    I created a new page and added the Coblocks hero block, while the Carousel Block plugin is activated. The block editor did not crash, I am not seeing any errors. I was also able to add the Coblock hero block in the Carousel block slides without issues. Please include the error message you are seeing. Make sure to check the console in your browser’s inspector as well. This may also be a Coblocks plugin issue.

    To override, you may have to use the unslick method first.

    $('.your-slider').slick('unslick'); then add your custom code. Overriding should work but I am not sure how your theme is set up. Unfortunately I cannot offer a lot of help with customization as it is outside the scope of the plugin. More options will be added soon to avoid custom coding.

    Thank you very much for the suggestions!

    • This reply was modified 1 month, 2 weeks ago by  virgildia.
    • This reply was modified 1 month, 2 weeks ago by  virgildia.
    • This reply was modified 1 month, 2 weeks ago by  virgildia.

    The blocks editor shows a controlled error with 3 buttons: Attempt recovery, Copy text and Copy error.

    Console shows:

    TypeError: this.activateMode is not a function
        at load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:351
        at f (blocks.build.js?ver=1:1)
        at Function.cf (blocks.build.js?ver=1:1)
        at N.d._createModes (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:351)
        at N.d.initialize (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:351)
        at N.d.initialize (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:351)
        at N.d.initialize (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:351)
        at N.d.b.View (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:345)
        at N.d.constructor (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:346)
        at N.d.constructor (load-scripts.php?c=0&load[]=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load[]=uest,media-views&ver=5.2:351)

    The error code is:

    _createModes/<@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:351:24813
    f@http://website.com/wp-content/plugins/carousel-block/dist/blocks.build.js?ver=1:1:5100
    cf@http://website.com/wp-content/plugins/carousel-block/dist/blocks.build.js?ver=1:1:47505
    _createModes@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:351:24773
    initialize@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:351:24182
    initialize@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:351:25820
    initialize@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:351:28692
    b.View@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:345:14137
    constructor@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:346:2616
    constructor@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:351:23629
    N/d<@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:345:22093
    N/d<@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:345:22093
    N/d<@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:345:22093
    23/wp.media@http://website.com/wp-admin/load-scripts.php?c=0&load%5B%5D=thickbox,hoverIntent,common,admin-bar,heartbeat,postbox,backbone,wp-backbone,media-models,wp-plupload,wp-mediaelement,wp-api-req&load%5B%5D=uest,media-views&ver=5.2:347:1153
    t@http://website.com/wp-includes/js/dist/edit-post.min.js?ver=3.3.4:12:7318
    Yf@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:67:42
    qg@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:92:302
    hi@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:104:285
    Qg@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:144:217
    Rg@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:145:76
    Sc@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:158:109
    Z@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:156:492
    ah@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:159:227
    xf@http://website.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:40:45
    

    And on the JS side, I unslick the slider but when I slick it again the parameters are still the same default.

    Thanks for the help!

    We’re seeing almost the same error as above (the one immediately prior to this post), but we’re not using Slick or Coblocks.

    • This reply was modified 1 month, 2 weeks ago by  JeremyEnglert.
    Plugin Author virgildia

    (@virgildia)

    @jeremyenglert have you found which WordPress plugin is causing the error?

    We disabled all plugins (besides Carousel Block) and then enabled them one by one. The issue only occurs when Carousel Block and Breadcrumb NavXT are both active.

    Plugin Author virgildia

    (@virgildia)

    I was able to reproduce the error with another plugin. I will fix this as soon as I can in the next plugin update.

    Plugin Author virgildia

    (@virgildia)

    This issue was fixed. Please update to the latest version of the plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.