Support » Plugin: Shortcake (Shortcode UI) » Compatibility issue with Post Type Archive Description Plugin

  • To reproduce:

    1. Fresh WP
    2. Install & activate Shortcake
    3. Register a shortcode and its UI, including editor styles
    4. Install & activate this plugin: https://wordpress.org/plugins/post-type-archive-descriptions/
    5. Create a custom post type (however you please)
    6. Navigate to Custom Post Type -> Archive Description
    7. Attempt to use shortcode

    Expected: Shortcode is rendered
    Actual: “Something’s rotten in the state of Denmark”

    Looks like this circles back to some kind of permissions checking (current_user_can()), which is probably not panning out well on a page that isn’t actually a post edit page.

    Could be something to look into? Let me know if you’d like more information.

    https://wordpress.org/plugins/shortcode-ui/

  • The topic ‘Compatibility issue with Post Type Archive Description Plugin’ is closed to new replies.