Support » Plugin: Flexible Elementor Panel » Compatibility issue with other plugins hooking into User Preferences area

  • Resolved Pixify

    (@pixify)


    Hello @webmatpro,

    Our plugin hooks into Elementor’s User Preferences area using the elementor/element/editor-preferences/preferences/before_section_end hook to add an important functionality in the editor.

    FEP v2.2.0 overwrites the complete User Preferences Model overwriting that control.

    We have some users reporting this behavior on sites using both the FEP and our plugin. I have tested it myself and can confirm the behavior.

    Ideally, it would be better if the Model takes into consideration the existing sections and controls, and extends the array to add/remove other sections/controls instead of fully overwriting it. This way, it ensures to play nicely with other plugins adding certain functionality in the “User Preferences” area.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Compatibility issue with other plugins hooking into User Preferences area’ is closed to new replies.